Ver código fonte

meta-oe: Remove using python2

This change makes the parsing go though, we still might have build
issues, which will be reported in world builds seprately

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 4 anos atrás
pai
commit
5057746583
35 arquivos alterados com 36 adições e 121 exclusões
  1. 1 1
      meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb
  2. 1 1
      meta-oe/recipes-connectivity/telepathy/telepathy-idle_0.2.0.bb
  3. 1 1
      meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb
  4. 1 1
      meta-oe/recipes-dbs/postgresql/postgresql.inc
  5. 3 3
      meta-oe/recipes-devtools/guider/guider_3.9.6.bb
  6. 1 1
      meta-oe/recipes-devtools/nanopb/nanopb_0.4.0.bb
  7. 1 1
      meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
  8. 1 1
      meta-oe/recipes-devtools/php/php_7.3.11.bb
  9. 0 18
      meta-oe/recipes-devtools/python/python-cpuset_1.6.bb
  10. 0 7
      meta-oe/recipes-devtools/python/python-distutils-extra.bb
  11. 0 13
      meta-oe/recipes-devtools/python/python-futures_3.3.0.bb
  12. 0 11
      meta-oe/recipes-devtools/python/python-jsmin_2.2.2.bb
  13. 0 12
      meta-oe/recipes-devtools/python/python-pytoml.inc
  14. 0 2
      meta-oe/recipes-devtools/python/python-pytoml_0.1.21.bb
  15. 0 2
      meta-oe/recipes-devtools/python/python-six_1.13.0.bb
  16. 0 19
      meta-oe/recipes-devtools/python/python-which_1.1.0.bb
  17. 0 0
      meta-oe/recipes-devtools/python/python3-pygobject/0001-python-pyobject-fix-install-dir.patch
  18. 5 6
      meta-oe/recipes-devtools/python/python3-pygobject_3.34.0.bb
  19. 1 1
      meta-oe/recipes-devtools/sip/sip_4.19.19.bb
  20. 1 1
      meta-oe/recipes-devtools/yasm/yasm_git.bb
  21. 1 1
      meta-oe/recipes-extended/collectd/collectd_5.8.1.bb
  22. 1 1
      meta-oe/recipes-extended/hplip/hplip_3.12.6.bb
  23. 4 4
      meta-oe/recipes-extended/iotop/iotop_0.6.bb
  24. 1 1
      meta-oe/recipes-extended/libimobiledevice/libplist_2.1.0.bb
  25. 2 2
      meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb
  26. 1 1
      meta-oe/recipes-extended/rrdtool/rrdtool_1.7.2.bb
  27. 1 1
      meta-oe/recipes-gnome/pyxdg/pyxdg_0.26.bb
  28. 1 1
      meta-oe/recipes-graphics/fvwm/fvwm_2.6.9.bb
  29. 1 1
      meta-oe/recipes-graphics/ttf-fonts/ttf-lohit_2.bb
  30. 1 1
      meta-oe/recipes-multimedia/mplayer/mpv_0.26.0.bb
  31. 1 1
      meta-oe/recipes-navigation/gpsd/gpsd_3.19.bb
  32. 1 1
      meta-oe/recipes-security/nmap/nmap_7.80.bb
  33. 1 1
      meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb
  34. 1 1
      meta-oe/recipes-support/system-config-keyboard/system-config-keyboard_1.4.0.bb
  35. 1 1
      meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb

+ 1 - 1
meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb

@@ -13,7 +13,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}/${PV}/${BP}.tar.bz2 \
 SRC_URI[md5sum] = "8ea16c6b3cc48097a8e62311fe0e25b9"
 SRC_URI[sha256sum] = "de67caa102aa4c8fbed5300e5a0262e40411c4cc79f4379a8d34eed797968fc3"
 
-inherit distutils cmake gettext
+inherit distutils3 cmake gettext
 
 do_install_append() {
     # these files seem to only be used by symbian and trigger QA warnings

+ 1 - 1
meta-oe/recipes-connectivity/telepathy/telepathy-idle_0.2.0.bb

@@ -11,7 +11,7 @@ SRC_URI = "http://telepathy.freedesktop.org/releases/${BPN}/${BPN}-${PV}.tar.gz
 SRC_URI[md5sum] = "92a2de5198284cbd3c430b0d1a971a86"
 SRC_URI[sha256sum] = "3013ad4b38d14ee630b8cc8ada5e95ccaa849b9a6fe15d2eaf6d0717d76f2fab"
 
-inherit autotools pkgconfig pythonnative
+inherit autotools pkgconfig python3native
 
 FILES_${PN} += "${datadir}/telepathy \
                 ${datadir}/dbus-1"

+ 1 - 1
meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb

@@ -16,4 +16,4 @@ SRC_URI[sha256sum] = "811040b647e5d5686f84db415efd697e6250008b112b6909ba77ac059e
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-inherit setuptools
+inherit setuptools3

+ 1 - 1
meta-oe/recipes-dbs/postgresql/postgresql.inc

@@ -37,7 +37,7 @@ LEAD_SONAME = "libpq.so"
 # LDFLAGS for shared libraries
 export LDFLAGS_SL = "${LDFLAGS}"
 
-inherit autotools pkgconfig perlnative pythonnative useradd update-rc.d systemd gettext cpan-base
+inherit autotools pkgconfig perlnative python3native useradd update-rc.d systemd gettext cpan-base
 
 CFLAGS += "-I${STAGING_INCDIR}/${PYTHON_DIR} -I${STAGING_INCDIR}/tcl8.6"
 

+ 3 - 3
meta-oe/recipes-devtools/guider/guider_3.9.6.bb

@@ -16,7 +16,7 @@ SRCREV = "fef25c41efb9bde0614ea477d0b90bd9565ae0b4"
 S = "${WORKDIR}/git"
 R = "${RECIPE_SYSROOT}"
 
-inherit distutils
+inherit distutils3
 
 GUIDER_OBJ = "guider.pyc"
 GUIDER_SCRIPT = "guider"
@@ -31,5 +31,5 @@ do_install() {
     install -v -m 0755 ${STAGING_LIBDIR_NATIVE}/python${PYTHON_BASEVERSION}/site-packages/${BPN}/${GUIDER_OBJ} ${D}${datadir}/${BPN}/${GUIDER_OBJ}
 }
 
-RDEPENDS_${PN} = "python-ctypes python-shell \
-                  python-json python-subprocess"
+RDEPENDS_${PN} = "python3-ctypes python3-shell \
+                  python3-json python3-subprocess"

+ 1 - 1
meta-oe/recipes-devtools/nanopb/nanopb_0.4.0.bb

@@ -9,7 +9,7 @@ SRCREV = "70f0de9877b1ce12abc0229d5df84db6349fcbfc"
 
 S = "${WORKDIR}/git"
 
-inherit cmake pythonnative
+inherit cmake python3native
 
 do_install_append() {
     install -Dm 0755 ${S}/generator/nanopb_generator.py ${D}${bindir}/nanopb_generator.py

+ 1 - 1
meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb

@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=be980eb7ccafe287cb438076a65e888c"
 DEPENDS = "openssl"
 DEPENDS_append_class-target = " nodejs-native"
 
-inherit pkgconfig pythonnative
+inherit pkgconfig python3native
 
 COMPATIBLE_MACHINE_armv4 = "(!.*armv4).*"
 COMPATIBLE_MACHINE_armv5 = "(!.*armv5).*"

+ 1 - 1
meta-oe/recipes-devtools/php/php_7.3.11.bb

@@ -37,7 +37,7 @@ S = "${WORKDIR}/php-${PV}"
 SRC_URI[md5sum] = "21b710b4126d4d54714de9693a6c7b0d"
 SRC_URI[sha256sum] = "92d1ff4b13c7093635f1ec338a5e6891ca99b10e65fbcadd527e5bb84d11b5e7"
 
-inherit autotools pkgconfig pythonnative gettext
+inherit autotools pkgconfig python3native gettext
 
 # phpize is not scanned for absolute paths by default (but php-config is).
 #

+ 0 - 18
meta-oe/recipes-devtools/python/python-cpuset_1.6.bb

@@ -1,18 +0,0 @@
-SUMMARY = "Cpuset is a Python application to make using the cpusets facilities in the Linux kernel easier"
-SECTION = "devel/python"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-
-S = "${WORKDIR}/git"
-SRCREV = "6c46d71a1c6ee711063153b9f7787280128f7252"
-SRC_URI = "git://github.com/lpechacek/cpuset.git;protocol=https;"
-
-inherit distutils
-
-RDEPENDS_${PN} = "\
-    python-core \
-    python-re \
-    python-logging \
-    python-textutils \
-    python-unixadmin \
-    "

+ 0 - 7
meta-oe/recipes-devtools/python/python-distutils-extra.bb

@@ -1,7 +0,0 @@
-require python-distutils-extra.inc
-
-inherit setuptools
-
-RDEPENDS_${PN} = "\
-    python-distutils \
-"

+ 0 - 13
meta-oe/recipes-devtools/python/python-futures_3.3.0.bb

@@ -1,13 +0,0 @@
-DESCRIPTION = "The concurrent.futures module provides a high-level interface for asynchronously executing callables."
-SECTION = "devel/python"
-LICENSE = "PSF"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=834d982f973c48b6d662b5944c5ab567"
-HOMEPAGE = "https://github.com/agronholm/pythonfutures"
-DEPENDS = "python"
-
-SRC_URI[md5sum] = "b43a39ae1475e3fd6940f2b4f7214675"
-SRC_URI[sha256sum] = "7e033af76a5e35f58e56da7a91e687706faf4e7bdfb2cbc3f2cca6b9bcda9794"
-
-inherit pypi setuptools
-
-BBCLASSEXTEND = "native nativesdk"

+ 0 - 11
meta-oe/recipes-devtools/python/python-jsmin_2.2.2.bb

@@ -1,11 +0,0 @@
-DESCRIPTION = "JavaScript minifier."
-HOMEPAGE = "https://github.com/tikitu/jsmin/"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3a3301ce2ad647e172f4a1016c67324d"
-
-inherit setuptools pypi
-SRC_URI[md5sum] = "00e7a3179a4591aab2ee707b3214e2fd"
-SRC_URI[sha256sum] = "b6df99b2cd1c75d9d342e4335b535789b8da9107ec748212706ef7bbe5c2553b"
-
-BBCLASSEXTEND = "native nativesdk"

+ 0 - 12
meta-oe/recipes-devtools/python/python-pytoml.inc

@@ -1,12 +0,0 @@
-SUMMARY = "A TOML-0.4.0 parser/writer for Python"
-HOMEPAGE = "https://pypi.python.org/pypi/pytoml/"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=cfff423699bdaef24331933ac4f56078"
-
-SRC_URI[md5sum] = "e59dd36a559dd2a876e4c149c69e947b"
-SRC_URI[sha256sum] = "8eecf7c8d0adcff3b375b09fe403407aa9b645c499e5ab8cac670ac4a35f61e7"
-
-inherit pypi
-
-BBCLASSEXTEND = "native nativesdk"

+ 0 - 2
meta-oe/recipes-devtools/python/python-pytoml_0.1.21.bb

@@ -1,2 +0,0 @@
-inherit pypi setuptools
-require python-pytoml.inc

+ 0 - 2
meta-oe/recipes-devtools/python/python-six_1.13.0.bb

@@ -1,2 +0,0 @@
-inherit pypi setuptools
-require recipes-devtools/python/python-six.inc

+ 0 - 19
meta-oe/recipes-devtools/python/python-which_1.1.0.bb

@@ -1,19 +0,0 @@
-DESCRIPTION = "which.py -- a portable GNU which replacement"
-HOMEPAGE = "http://code.google.com/p/which/"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=030b09798681482b9ad12ac47be496ea"
-
-inherit setuptools pypi python-dir
-
-SRCREV = "425bdeeb2d87c36e2313dc4b8d69ff2bb5a02ee9"
-PYPI_SRC_URI = "git://github.com/trentm/which"
-
-S = "${WORKDIR}/git"
-
-do_install_append() {
-    rmdir -p --ignore-fail-on-non-empty ${D}${STAGING_BINDIR_NATIVE}
-    rmdir -p --ignore-fail-on-non-empty ${D}${datadir}
-}
-
-BBCLASSEXTEND = "native nativesdk"

+ 0 - 0
meta-oe/recipes-devtools/python/python-pygobject/0001-python-pyobject-fix-install-dir.patch → meta-oe/recipes-devtools/python/python3-pygobject/0001-python-pyobject-fix-install-dir.patch


+ 5 - 6
meta-oe/recipes-devtools/python/python-pygobject_3.34.0.bb → meta-oe/recipes-devtools/python/python3-pygobject_3.34.0.bb

@@ -5,14 +5,13 @@ LICENSE = "LGPLv2.1"
 LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
 
 GNOMEBASEBUILDCLASS = "meson"
-inherit gnomebase gobject-introspection distutils-base upstream-version-is-even
+inherit gnomebase gobject-introspection distutils3-base upstream-version-is-even
 
-DEPENDS += "python glib-2.0"
+DEPENDS += "python3 glib-2.0"
 
 SRCNAME = "pygobject"
 SRC_URI = " \
     http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \
-    file://0001-python-pyobject-fix-install-dir.patch \
 "
 
 SRC_URI[md5sum] = "ca1dc4f31c1d6d283758e8f315a88ab6"
@@ -22,12 +21,12 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
 
 UNKNOWN_CONFIGURE_WHITELIST = "introspection"
 
-PACKAGECONFIG ??= "stagedir"
+PACKAGECONFIG ??= ""
 
 PACKAGECONFIG[cairo] = "-Dpycairo=true,-Dpycairo=false, cairo python-pycairo, python-pycairo"
 PACKAGECONFIG[tests] = "-Dtests=true, -Dtests=false, , "
-PACKAGECONFIG[python] = "-Dpython=python3, -Dpython=python2, , "
-PACKAGECONFIG[stagedir] = "-Dstagedir=${PYTHON_SITEPACKAGES_DIR}, -Dstagedir="", , "
+
+EXTRA_OEMESON_append = " -Dpython=python3"
 
 BBCLASSEXTEND = "native"
 RDEPENDS_${PN} = "python-pkgutil"

+ 1 - 1
meta-oe/recipes-devtools/sip/sip_4.19.19.bb

@@ -2,7 +2,7 @@ require sip.inc
 
 DEPENDS = "python"
 
-inherit python-dir pythonnative
+inherit python3-dir python3native
 
 PACKAGES += "python-sip"
 

+ 1 - 1
meta-oe/recipes-devtools/yasm/yasm_git.bb

@@ -13,7 +13,7 @@ SRC_URI = "git://github.com/yasm/yasm.git"
 
 S = "${WORKDIR}/git"
 
-inherit autotools gettext pythonnative
+inherit autotools gettext python3native
 
 CACHED_CONFIGUREVARS = "CCLD_FOR_BUILD='${CC_FOR_BUILD}'"
 

+ 1 - 1
meta-oe/recipes-extended/collectd/collectd_5.8.1.bb

@@ -19,7 +19,7 @@ SRC_URI = "http://collectd.org/files/collectd-${PV}.tar.bz2 \
 SRC_URI[md5sum] = "bfce96c42cede5243028510bcc57c1e6"
 SRC_URI[sha256sum] = "e796fda27ce06377f491ad91aa286962a68c2b54076aa77a29673d53204453da"
 
-inherit autotools pythonnative update-rc.d pkgconfig systemd
+inherit autotools python3native update-rc.d pkgconfig systemd
 
 SYSTEMD_SERVICE_${PN} = "collectd.service"
 

+ 1 - 1
meta-oe/recipes-extended/hplip/hplip_3.12.6.bb

@@ -14,7 +14,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \
 
 DEPENDS += "cups python libusb"
 
-inherit autotools-brokensep python-dir pythonnative pkgconfig
+inherit autotools-brokensep python3-dir python3native pkgconfig
 
 export STAGING_INCDIR
 export STAGING_LIBDIR

+ 4 - 4
meta-oe/recipes-extended/iotop/iotop_0.6.bb

@@ -15,13 +15,13 @@ SRC_URI[sha256sum] = "3adea2a24eda49bbbaeb4e6ed2042355b441dbd7161e883067a02bfc8d
 UPSTREAM_CHECK_URI = "http://repo.or.cz/iotop.git/tags"
 UPSTREAM_CHECK_REGEX = "iotop-(?P<pver>\d+(\.\d+)+)"
 
-inherit distutils
+inherit distutils3
 
 do_install_append() {
     rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.pyo || true
     rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.py  || true
 }
 
-RDEPENDS_${PN} = "python-curses python-textutils \
-                  python-codecs python-ctypes python-pprint \
-                  python-shell python-subprocess python-core"
+RDEPENDS_${PN} = "python3-curses python3-textutils \
+                  python3-codecs python3-ctypes python3-pprint \
+                  python3-shell python3-subprocess python3-core"

+ 1 - 1
meta-oe/recipes-extended/libimobiledevice/libplist_2.1.0.bb

@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ebb5c50ab7cab4baeffba14977030c07 \
 
 DEPENDS = "libxml2 glib-2.0 swig python"
 
-inherit autotools pkgconfig pythonnative
+inherit autotools pkgconfig python3native
 
 SRCREV = "3df02d4d0e9008771e8622fdc10de8333b3f0d85"
 SRC_URI = "git://github.com/libimobiledevice/libplist;protocol=https \

+ 2 - 2
meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb

@@ -5,9 +5,9 @@ LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://../COPYING;md5=75859989545e37968a99b631ef42722e"
 SECTION = "System/Management"
 
-inherit setuptools
+inherit setuptools3
 
-DEPENDS = "python-native python-pywbem-native python-m2crypto python-pywbem"
+DEPENDS = "python3-native python3-pywbem-native python3-m2crypto python-pywbem"
 
 SRC_URI = "http://fedorahosted.org/released/${BPN}/${BP}.tar.gz \
           "

+ 1 - 1
meta-oe/recipes-extended/rrdtool/rrdtool_1.7.2.bb

@@ -15,7 +15,7 @@ SRC_URI = "\
 
 S = "${WORKDIR}/git"
 
-inherit cpan autotools-brokensep gettext pythonnative python-dir systemd
+inherit cpan autotools-brokensep gettext python3native python3-dir systemd
 
 BBCLASSEXTEND = "native"
 

+ 1 - 1
meta-oe/recipes-gnome/pyxdg/pyxdg_0.26.bb

@@ -7,6 +7,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=f30a9716ef3762e3467a2f62bf790f0a"
 SRCREV = "7db14dcf4c4305c3859a2d9fcf9f5da2db328330"
 SRC_URI = "git://anongit.freedesktop.org/xdg/pyxdg"
 
-inherit distutils
+inherit distutils3
 
 S = "${WORKDIR}/git"

+ 1 - 1
meta-oe/recipes-graphics/fvwm/fvwm_2.6.9.bb

@@ -40,7 +40,7 @@ SRCREV = "88eab6dc16da6e5dd25fe97fbb56b96ef0d58657"
 
 S = "${WORKDIR}/git"
 
-inherit autotools gettext update-alternatives pkgconfig pythonnative perlnative features_check
+inherit autotools gettext update-alternatives pkgconfig python3native perlnative features_check
 # depends on virtual/libx11
 REQUIRED_DISTRO_FEATURES = "x11"
 

+ 1 - 1
meta-oe/recipes-graphics/ttf-fonts/ttf-lohit_2.bb

@@ -15,7 +15,7 @@ S = "${WORKDIR}/git"
 FONT_PACKAGES = "${PN}"
 FILES_${PN} = "${datadir}"
 
-inherit pythonnative
+inherit python3native
 
 do_compile() {
     cd ${S}; make ttf;

+ 1 - 1
meta-oe/recipes-multimedia/mplayer/mpv_0.26.0.bb

@@ -24,7 +24,7 @@ SRC_URI[waf.sha256sum] = "01bf2beab2106d1558800c8709bc2c8e496d3da4a2ca343fe091f2
 
 S = "${WORKDIR}/git"
 
-inherit waf pkgconfig pythonnative features_check
+inherit waf pkgconfig python3native features_check
 
 LUA ?= "lua"
 LUA_mips64  = ""

+ 1 - 1
meta-oe/recipes-navigation/gpsd/gpsd_3.19.bb

@@ -12,7 +12,7 @@ SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \
 SRC_URI[md5sum] = "b3bf88706794eb8e5f2c2543bf7ba87b"
 SRC_URI[sha256sum] = "27dd24d45b2ac69baab7933da2bf6ae5fb0be90130f67e753c110a3477155f39"
 
-inherit scons update-rc.d python-dir pythonnative systemd update-alternatives
+inherit scons update-rc.d python3-dir python3native systemd update-alternatives
 
 INITSCRIPT_PACKAGES = "gpsd-conf"
 INITSCRIPT_NAME = "gpsd"

+ 1 - 1
meta-oe/recipes-security/nmap/nmap_7.80.bb

@@ -15,7 +15,7 @@ SRC_URI = "http://nmap.org/dist/${BP}.tar.bz2 \
 SRC_URI[md5sum] = "d37b75b06d1d40f27b76d60db420a1f5"
 SRC_URI[sha256sum] = "fcfa5a0e42099e12e4bf7a68ebe6fde05553383a682e816a7ec9256ab4773faa"
 
-inherit autotools-brokensep pkgconfig pythonnative
+inherit autotools-brokensep pkgconfig python3native
 
 PACKAGECONFIG ?= "ncat nping ndiff pcap"
 

+ 1 - 1
meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb

@@ -12,7 +12,7 @@ SRC_URI = "git://github.com/Datera/lio-utils.git \
 SRCREV = "0ac9091c1ff7a52d5435a4f4449e82637142e06e"
 S = "${WORKDIR}/git"
 
-inherit distutils
+inherit distutils3
 
 EXTRA_OEMAKE += "DESTDIR=${D}"
 

+ 1 - 1
meta-oe/recipes-support/system-config-keyboard/system-config-keyboard_1.4.0.bb

@@ -6,7 +6,7 @@ SRC_URI = "https://fedorahosted.org/releases/s/y/${BPN}/${BP}.tar.bz2"
 SRC_URI[md5sum] = "c267db0ee7a2131ba418399dc17f9e72"
 SRC_URI[sha256sum] = "218c883e4e2bfcc82bfe07e785707b5c2ece28df772f2155fd044b9bb1614284"
 
-inherit python-dir gettext
+inherit python3-dir gettext
 DEPENDS += "intltool-native gettext-native"
 
 EXTRA_OEMAKE = " \

+ 1 - 1
meta-oe/recipes-test/cxxtest/cxxtest_4.4.bb

@@ -10,7 +10,7 @@ SRC_URI[sha256sum] = "1c154fef91c65dbf1cd4519af7ade70a61d85a923b6e0c0b007dc7f489
 
 S = "${WORKDIR}/cxxtest-${PV}/python"
 
-inherit distutils
+inherit distutils3
 
 do_install_append() {
     install -d ${D}${includedir}