mpv_0.26.0.bb 2.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283
  1. SUMMARY = "Open Source multimedia player"
  2. DESCRIPTION = "mpv is a fork of mplayer2 and MPlayer. It shares some features with the former projects while introducing many more."
  3. SECTION = "multimedia"
  4. HOMEPAGE = "http://www.mpv.io/"
  5. DEPENDS = "zlib ffmpeg jpeg virtual/libx11 xsp libxv \
  6. libxscrnsaver libv4l libxinerama \
  7. "
  8. REQUIRED_DISTRO_FEATURES = "x11"
  9. LICENSE = "GPLv2+"
  10. LIC_FILES_CHKSUM = "file://LICENSE;md5=91f1cb870c1cc2d31351a4d2595441cb"
  11. # While this item does not require it, it depends on ffmpeg which does
  12. LICENSE_FLAGS = "commercial"
  13. SRCREV_mpv = "4db82f04502cbcd20d9a975df9dfde91d8c389e3"
  14. SRC_URI = " \
  15. git://github.com/mpv-player/mpv;name=mpv \
  16. http://www.freehackers.org/~tnagy/release/waf-1.8.12;name=waf;downloadfilename=waf;subdir=git \
  17. "
  18. SRC_URI[waf.md5sum] = "cef4ee82206b1843db082d0b0506bf71"
  19. SRC_URI[waf.sha256sum] = "01bf2beab2106d1558800c8709bc2c8e496d3da4a2ca343fe091f22fca60c98b"
  20. S = "${WORKDIR}/git"
  21. inherit waf pkgconfig python3native features_check
  22. LUA ?= "lua"
  23. LUA_mips64 = ""
  24. LUA_aarch64 = ""
  25. LUA_powerpc64 = ""
  26. LUA_powerpc64le = ""
  27. LUA_powerpc = ""
  28. # Note: both lua and libass are required to get on-screen-display (controls)
  29. PACKAGECONFIG ??= " \
  30. ${LUA} \
  31. libass \
  32. ${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)} \
  33. "
  34. PACKAGECONFIG_remove_aarch64 = "lua"
  35. PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,libdrm"
  36. PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/mesa"
  37. PACKAGECONFIG[lua] = "--enable-lua,--disable-lua,lua luajit"
  38. PACKAGECONFIG[libass] = "--enable-libass,--disable-libass,libass"
  39. PACKAGECONFIG[libarchive] = "--enable-libarchive,--disable-libarchive,libarchive"
  40. PACKAGECONFIG[jack] = "--enable-jack, --disable-jack, jack"
  41. PACKAGECONFIG[vaapi] = "--enable-vaapi, --disable-vaapi,libva"
  42. PACKAGECONFIG[vdpau] = "--enable-vdpau, --disable-vdpau,libvdpau"
  43. PACKAGECONFIG[wayland] = "--enable-wayland, --disable-wayland,wayland libxkbcommon"
  44. SIMPLE_TARGET_SYS = "${@'${TARGET_SYS}'.replace('${TARGET_VENDOR}', '')}"
  45. EXTRA_OECONF = " \
  46. --prefix=${prefix} \
  47. --target=${SIMPLE_TARGET_SYS} \
  48. --confdir=${sysconfdir} \
  49. --datadir=${datadir} \
  50. --disable-manpage-build \
  51. --disable-gl \
  52. --disable-libsmbclient \
  53. --disable-encoding \
  54. --disable-libbluray \
  55. --disable-dvdread \
  56. --disable-dvdnav \
  57. --disable-cdda \
  58. --disable-uchardet \
  59. --disable-rubberband \
  60. --disable-lcms2 \
  61. --disable-vapoursynth \
  62. --disable-vapoursynth-lazy \
  63. ${PACKAGECONFIG_CONFARGS} \
  64. "
  65. adjust_waf_perms() {
  66. chmod +x ${S}/waf
  67. }
  68. do_patch[postfuncs] += "adjust_waf_perms"
  69. FILES_${PN} += "${datadir}/icons"