fvwm_2.6.9.bb 2.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109
  1. SUMMARY = "F Virtual Window Manager "
  2. HOMEPAGE = "http://www.fvwm.org/"
  3. SECTION = "x11/wm"
  4. LICENSE = "GPLv2"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=f8204787357db6ea518dcc9b6cf08388"
  6. DEPENDS = " \
  7. bison-native \
  8. flex-native \
  9. freetype-native \
  10. gettext-native \
  11. libxslt-native \
  12. fontconfig \
  13. libice \
  14. libpng \
  15. librsvg \
  16. libsm \
  17. libxau \
  18. libxcb \
  19. libxcursor \
  20. libxdmcp \
  21. libxext \
  22. libxfixes \
  23. libxft \
  24. libxinerama \
  25. libxml2 \
  26. libxrender \
  27. libxt \
  28. virtual/libx11 \
  29. xrandr \
  30. zlib \
  31. "
  32. SRC_URI = " \
  33. git://github.com/fvwmorg/fvwm.git;protocol=https \
  34. file://0001-Fix-compilation-for-disabled-gnome.patch \
  35. "
  36. SRCREV = "88eab6dc16da6e5dd25fe97fbb56b96ef0d58657"
  37. S = "${WORKDIR}/git"
  38. inherit autotools gettext update-alternatives pkgconfig python3native perlnative features_check
  39. # depends on virtual/libx11
  40. REQUIRED_DISTRO_FEATURES = "x11"
  41. ALTERNATIVE_${PN} = "x-window-manager"
  42. ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/fvwm"
  43. ALTERNATIVE_PRIORITY[x-window-manager] = "20"
  44. EXTRA_OECONF = " \
  45. --disable-bidi \
  46. --disable-fontconfigtest \
  47. --disable-htmldoc \
  48. --disable-imlibtest \
  49. --disable-nls \
  50. --disable-perllib \
  51. --disable-rsvg \
  52. --disable-shape \
  53. --disable-sm \
  54. --disable-xfttest \
  55. --with-imlib-exec-prefix=/nonexistent \
  56. --with-imlib-prefix=/nonexistent \
  57. --without-ncurses-library \
  58. --without-readline-library \
  59. --without-rplay-library \
  60. --without-stroke-library \
  61. --without-termcap-library \
  62. --without-xpm-library \
  63. ac_cv_func_mkstemp=no \
  64. has_safety_mkstemp=yes \
  65. "
  66. # show the exact commands in the log file
  67. EXTRA_OEMAKE = " \
  68. V=1 \
  69. "
  70. do_install_append() {
  71. install -d -m 0755 ${D}/${sysconfdir}/xdg/fvwm
  72. # You can install the config file here
  73. install -d -m 0755 ${D}/${datadir}/fvwm
  74. touch ${D}/${datadir}/fvwm/ConfigFvwmDefaults
  75. }
  76. # the only needed packages (note: locale packages are automatically generated
  77. # as well)
  78. PACKAGES = " \
  79. ${PN} \
  80. ${PN}-dbg \
  81. "
  82. # minimal set of binaries
  83. FILES_${PN} = " \
  84. ${bindir}/fvwm \
  85. ${bindir}/fvwm-root \
  86. ${datadir}/fvwm/ConfigFvwmDefaults \
  87. "
  88. RDEPENDS_${PN} = " \
  89. xuser-account \
  90. "
  91. # by default a lot of stuff is installed and it's not easy to control what to
  92. # install, so install everything, but skip the check
  93. INSANE_SKIP_${PN} = " \
  94. installed-vs-shipped \
  95. "