openlmi-tools_0.10.5.bb 891 B

1234567891011121314151617181920212223242526
  1. SUMMARY = "Set of CLI tools for Openlmi providers"
  2. DESCRIPTION = "openlmi-tools is a set of command line tools for Openlmi providers."
  3. HOMEPAGE = "http://www.openlmi.org/"
  4. LICENSE = "GPLv2+"
  5. LIC_FILES_CHKSUM = "file://../COPYING;md5=75859989545e37968a99b631ef42722e"
  6. SECTION = "System/Management"
  7. inherit setuptools3
  8. DEPENDS = "python3-native python3-pywbem-native python3-m2crypto python-pywbem"
  9. SRC_URI = "http://fedorahosted.org/released/${BPN}/${BP}.tar.gz \
  10. "
  11. SRC_URI[md5sum] = "e156246cb7b49753db82f4ddf7f03e50"
  12. SRC_URI[sha256sum] = "292b8f5f2250655a4add8183c529b73358bc980bd4f23cfa484a940953fce9e4"
  13. S = "${WORKDIR}/${BP}/cli"
  14. do_configure_prepend() {
  15. sed 's/@@VERSION@@/$(VERSION)/g' setup.py.skel >setup.py
  16. }
  17. python() {
  18. if 'meta-python' not in d.getVar('BBFILE_COLLECTIONS').split():
  19. raise bb.parse.SkipRecipe('Requires meta-python to be present.')
  20. }