nanopb_0.4.0.bb 827 B

12345678910111213141516171819202122232425262728
  1. DESCRIPTION="Protocol Buffers with small code size"
  2. LICENSE="Zlib"
  3. LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9db4b73a55a3994384112efcdb37c01f"
  4. DEPENDS = "protobuf-native"
  5. SRC_URI = "git://github.com/nanopb/nanopb.git"
  6. SRCREV = "70f0de9877b1ce12abc0229d5df84db6349fcbfc"
  7. S = "${WORKDIR}/git"
  8. inherit cmake python3native
  9. do_install_append() {
  10. install -Dm 0755 ${S}/generator/nanopb_generator.py ${D}${bindir}/nanopb_generator.py
  11. install -Dm 0755 ${S}/generator/protoc-gen-nanopb ${D}${bindir}/protoc-gen-nanopb
  12. install -Dm 0755 ${S}/generator/proto/__init__.py ${D}${PYTHON_SITEPACKAGES_DIR}/proto/__init__.py
  13. }
  14. FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
  15. FILES_${PN}-dev += "${libdir}/cmake/${BPN}"
  16. RDEPENDS_${PN} += "\
  17. ${PYTHON_PN}-protobuf \
  18. protobuf-compiler \
  19. "
  20. BBCLASSEXTEND = "native nativesdk"