nmap_7.80.bb 2.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. SUMMARY = "network auditing tool"
  2. DESCRIPTION = "Nmap ("Network Mapper") is a free and open source (license) utility for network discovery and security auditing.\nGui support via appending to IMAGE_FEATURES x11-base in local.conf"
  3. SECTION = "security"
  4. LICENSE = "GPL-2.0"
  5. LIC_FILES_CHKSUM = "file://COPYING;beginline=7;endline=12;md5=66938a7e5b4c118eda78271de14874c2"
  6. SRC_URI = "http://nmap.org/dist/${BP}.tar.bz2 \
  7. file://nmap-redefine-the-python-library-dir.patch \
  8. file://nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch \
  9. file://0001-Include-time.h-header-to-pass-clang-compilation.patch \
  10. file://0002-Fix-building-with-libc.patch \
  11. "
  12. SRC_URI[md5sum] = "d37b75b06d1d40f27b76d60db420a1f5"
  13. SRC_URI[sha256sum] = "fcfa5a0e42099e12e4bf7a68ebe6fde05553383a682e816a7ec9256ab4773faa"
  14. inherit autotools-brokensep pkgconfig python3native
  15. PACKAGECONFIG ?= "ncat nping ndiff pcap"
  16. PACKAGECONFIG[pcap] = "--with-pcap=linux, --without-pcap, libpcap, libpcap"
  17. PACKAGECONFIG[pcre] = "--with-libpcre=${STAGING_LIBDIR}/.., --with-libpcre=included, libpcre"
  18. PACKAGECONFIG[ssl] = "--with-openssl=${STAGING_LIBDIR}/.., --without-openssl, openssl, openssl"
  19. PACKAGECONFIG[ssh2] = "--with-openssh2=${STAGING_LIBDIR}/.., --without-openssh2, libssh2, libssh2"
  20. PACKAGECONFIG[libz] = "--with-libz=${STAGING_LIBDIR}/.., --without-libz, zlib, zlib"
  21. #disable/enable packages
  22. PACKAGECONFIG[nping] = ",--without-nping,"
  23. PACKAGECONFIG[ncat] = ",--without-ncat,"
  24. PACKAGECONFIG[ndiff] = ",--without-ndiff,python"
  25. PACKAGECONFIG[update] = ",--without-nmap-update,"
  26. EXTRA_OECONF = "--with-libdnet=included --with-liblinear=included --without-subversion --with-liblua=included"
  27. # zenmap needs python-pygtk which has been removed
  28. # it also only works with python2
  29. # disable for now until py3 is supported
  30. EXTRA_OECONF += "--without-zenmap"
  31. export PYTHON_SITEPACKAGES_DIR
  32. do_configure() {
  33. autoconf
  34. install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
  35. install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
  36. oe_runconf
  37. }
  38. FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR} ${datadir}/ncat"
  39. RDEPENDS_${PN} = "python"