hplip_3.12.6.bb 2.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475
  1. SUMMARY = "HP Linux Imaging and Printing"
  2. LICENSE="GPLv2"
  3. LIC_FILES_CHKSUM = "file://COPYING;md5=442bb3cbbeeb60643a87325718b8a8ee"
  4. PR = "r1"
  5. SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \
  6. file://setup-add-sleep-after-cups-reset.patch \
  7. file://fix-libusb-paths.patch \
  8. file://cups-1.6.patch \
  9. file://configure.patch \
  10. file://0001-include-cups-ppd.h-for-missing-ppd-definitions.patch \
  11. "
  12. DEPENDS += "cups python libusb"
  13. inherit autotools-brokensep python3-dir python3native pkgconfig
  14. export STAGING_INCDIR
  15. export STAGING_LIBDIR
  16. EXTRA_OECONF += "\
  17. LIBUSBINCLUDEROOT=${STAGING_INCDIR} \
  18. --disable-network-build \
  19. --disable-doc-build \
  20. --disable-pp-build \
  21. --disable-scan-build \
  22. --disable-gui-build \
  23. --disable-fax-build \
  24. --disable-policykit \
  25. --disable-qt4 \
  26. --disable-qt3 \
  27. --disable-dbus-build \
  28. --disable-foomatic-drv-install \
  29. --enable-foomatic-ppd-install \
  30. --enable-foomatic-rip-hplip-install \
  31. --with-cupsbackenddir=${libdir}/cups/backend \
  32. --with-cupsfilterdir=${libdir}/cups/filter \
  33. "
  34. PACKAGES += "${PN}-ppd ${PN}-cups ${PN}-backend ${PN}-filter ${PN}-hal"
  35. RDEPENDS_${PN} += " \
  36. python \
  37. python-syslog \
  38. python-pprint \
  39. python-compression \
  40. python-shell \
  41. python-xml \
  42. python-unixadmin \
  43. python-html \
  44. python-resource \
  45. python-terminal \
  46. python-subprocess\
  47. "
  48. RDEPENDS_${PN}-filter += "perl"
  49. # need to snag the debug file or OE will fail on backend package
  50. FILES_${PN}-dbg += "\
  51. ${libdir}/cups/backend/.debug \
  52. ${PYTHON_SITEPACKAGES_DIR}/.debug \
  53. ${libdir}/cups/filter/.debug "
  54. FILES_${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/*.la"
  55. FILES_${PN}-ppd = "${datadir}/ppd"
  56. FILES_${PN}-cups = "${datadir}/cups"
  57. FILES_${PN}-backend = "${libdir}/cups/backend"
  58. FILES_${PN}-filter = "${libdir}/cups/filter"
  59. FILES_${PN}-hal = "${datadir}/hal"
  60. FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/*.so"
  61. SRC_URI[md5sum] = "5303938e8630775ea6fb383af85775e5"
  62. SRC_URI[sha256sum] = "54578000792969adb583e75efeacb9c46ab69659ec7e9424de390613f3595775"