iotop_0.6.bb 1.0 KB

123456789101112131415161718192021222324252627
  1. SUMMARY = "Simple top-like I/O monitor"
  2. DESCRIPTION = "iotop does for I/O usage what top(1) does for CPU usage. \
  3. It watches I/O usage information output by the Linux kernel and displays \
  4. a table of current I/O usage by processes on the system."
  5. HOMEPAGE = "http://guichaz.free.fr/iotop/"
  6. LICENSE = "GPLv2+"
  7. LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
  8. SRC_URI = "http://guichaz.free.fr/iotop/files/${BP}.tar.bz2"
  9. SRC_URI[md5sum] = "5ef9456b26d7694abf3101a72e1e0d1d"
  10. SRC_URI[sha256sum] = "3adea2a24eda49bbbaeb4e6ed2042355b441dbd7161e883067a02bfc8dcef75b"
  11. UPSTREAM_CHECK_URI = "http://repo.or.cz/iotop.git/tags"
  12. UPSTREAM_CHECK_REGEX = "iotop-(?P<pver>\d+(\.\d+)+)"
  13. inherit distutils3
  14. do_install_append() {
  15. rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.pyo || true
  16. rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.py || true
  17. }
  18. RDEPENDS_${PN} = "python3-curses python3-textutils \
  19. python3-codecs python3-ctypes python3-pprint \
  20. python3-shell python3-subprocess python3-core"