ソースを参照

use weak assignments for PNBLACKLIST in recipe files

Make sure PNBLACKLIST assignments in recipe files use weak assignment,
so they can be overridden in, for example, local.conf files.

Signed-off-by: Robert P. J. Day <rpjday@crashcourse.ca>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Robert P. J. Day 4 年 前
コミット
d7f5367b53

+ 1 - 1
meta-networking/recipes-netkit/netkit-rusers/netkit-rusers_0.17.bb

@@ -69,4 +69,4 @@ RDEPENDS_${PN}-server += "tcp-wrappers xinetd rpcbind"
 
 # http://errors.yoctoproject.org/Errors/Details/186962/
 COMPATIBLE_HOST_libc-musl = 'null'
-PNBLACKLIST[netkit-rusers] = "Fails to build rup.c:51:10: fatal error: rstat.h: No such file or directory"
+PNBLACKLIST[netkit-rusers] ?= "Fails to build rup.c:51:10: fatal error: rstat.h: No such file or directory"

+ 1 - 1
meta-networking/recipes-support/drbd/drbd_9.0.19-1.bb

@@ -22,4 +22,4 @@ do_install () {
     oe_runmake install DESTDIR="${D}"
 }
 
-PNBLACKLIST[drbd] = "Kernel module Needs forward porting to kernel 5.2+"
+PNBLACKLIST[drbd] ?= "Kernel module Needs forward porting to kernel 5.2+"

+ 1 - 1
meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb

@@ -36,4 +36,4 @@ FILES_${PN}-dbg += "${libexecdir}/lowpan-tools/.debug/"
 PACKAGES =+ "${PN}-python"
 FILES_${PN}-python = "${libdir}/python*"
 
-PNBLACKLIST[lowpan-tools] = "WARNING these tools are deprecated! Use wpan-tools instead"
+PNBLACKLIST[lowpan-tools] ?= "WARNING these tools are deprecated! Use wpan-tools instead"

+ 1 - 1
meta-oe/recipes-devtools/nanopb/nanopb_0.4.0.bb

@@ -27,4 +27,4 @@ RDEPENDS_${PN} += "\
 
 BBCLASSEXTEND = "native nativesdk"
 
-PNBLACKLIST[nanopb] = "Needs forward porting to use python3"
+PNBLACKLIST[nanopb] ?= "Needs forward porting to use python3"

+ 1 - 1
meta-oe/recipes-extended/socketcan/can-isotp_git.bb

@@ -11,4 +11,4 @@ inherit module
 
 EXTRA_OEMAKE += "KERNELDIR=${STAGING_KERNEL_DIR}"
 
-PNBLACKLIST[can-isotp] = "Kernel module Needs forward porting to kernel 5.2+"
+PNBLACKLIST[can-isotp] ?= "Kernel module Needs forward porting to kernel 5.2+"

+ 1 - 1
meta-oe/recipes-kernel/bpftool/bpftool.bb

@@ -32,4 +32,4 @@ python do_package_prepend() {
 }
 
 B = "${WORKDIR}/${BPN}-${PV}"
-PNBLACKLIST[bpftool] = "Needs forward porting to kernel 5.2+"
+PNBLACKLIST[bpftool] ?= "Needs forward porting to kernel 5.2+"