lowpan-tools_git.bb 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. SUMMARY = "Utilities for managing the Linux LoWPAN stack"
  2. DESCRIPTION = "This is a set of utils to manage the Linux LoWPAN stack. \
  3. The LoWPAN stack aims for IEEE 802.15.4-2003 (and for lesser extent IEEE 802.15.4-2006) compatibility."
  4. SECTION = "net"
  5. LICENSE = "GPLv2"
  6. LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
  7. DEPENDS = "flex-native bison-native libnl python"
  8. PV = "0.3.1+git${SRCPV}"
  9. SRC_URI = "git://github.com/linux-wpan/lowpan-tools \
  10. file://no-help2man.patch \
  11. file://0001-Fix-build-errors-with-clang.patch \
  12. file://0001-addrdb-coord-config-parse.y-add-missing-time.h-inclu.patch \
  13. file://0001-src-iz.c-Undef-dprintf-before-redefining.patch \
  14. file://0001-Remove-newline-from-format-line.patch \
  15. file://0001-coordinator-Fix-strncpy-range-warning.patch \
  16. file://0001-Fix-potential-string-truncation-in-strncpy.patch \
  17. "
  18. SRCREV = "1c2d8674cc6f4b1166a066e8822e295c105ae7a2"
  19. S = "${WORKDIR}/git"
  20. inherit autotools python3-dir pkgconfig
  21. CACHED_CONFIGUREVARS += "am_cv_python_pythondir=${PYTHON_SITEPACKAGES_DIR}/lowpan-tools"
  22. CFLAGS += "-Wno-initializer-overrides"
  23. do_install_append() {
  24. rmdir ${D}${localstatedir}/run
  25. }
  26. FILES_${PN}-dbg += "${libexecdir}/lowpan-tools/.debug/"
  27. PACKAGES =+ "${PN}-python"
  28. FILES_${PN}-python = "${libdir}/python*"
  29. PNBLACKLIST[lowpan-tools] ?= "WARNING these tools are deprecated! Use wpan-tools instead"