bpftool.bb 898 B

1234567891011121314151617181920212223242526272829303132333435
  1. SUMMARY = "Inspect and manipulate eBPF programs and maps"
  2. DESCRIPTION = "bpftool is a kernel tool for inspection and simple manipulation \
  3. of eBPF programs and maps."
  4. LICENSE = "GPLv2"
  5. DEPENDS = "binutils elfutils"
  6. PROVIDES = "virtual/bpftool"
  7. inherit bash-completion kernelsrc kernel-arch
  8. do_populate_lic[depends] += "virtual/kernel:do_patch"
  9. EXTRA_OEMAKE = "V=1 -C ${S}/tools/bpf/bpftool O=${B} CROSS=${TARGET_PREFIX} CC="${CC}" LD="${LD}" AR=${AR} ARCH=${ARCH}"
  10. SECURITY_CFLAGS = ""
  11. do_configure[depends] += "virtual/kernel:do_shared_workdir"
  12. COMPATIBLE_HOST_libc-musl = 'null'
  13. do_compile() {
  14. oe_runmake
  15. }
  16. do_install() {
  17. oe_runmake DESTDIR=${D} install
  18. }
  19. PACKAGE_ARCH = "${MACHINE_ARCH}"
  20. python do_package_prepend() {
  21. d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0])
  22. }
  23. B = "${WORKDIR}/${BPN}-${PV}"
  24. PNBLACKLIST[bpftool] ?= "Needs forward porting to kernel 5.2+"