netkit-rusers_0.17.bb 2.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. DESCRIPTION = "netkit-rusers includes rusers - Displays who is logged in to machines on local network \
  2. rusersd - Logged in users server"
  3. HOMEPAGE = "ftp://ftp.uk.linux.org/pub/linux/Networking/netkit"
  4. SECTION = "net"
  5. LICENSE = "BSD-3-Clause"
  6. LIC_FILES_CHKSUM = "file://rusers/rusers.c;beginline=2;endline=3;md5=f4fc634a4ce8c569911196b72b10770e"
  7. DEPENDS = " tcp-wrappers libtirpc rpcbind rpcsvc-proto rpcsvc-proto-native"
  8. SRC_URI = "http://http.debian.net/debian/pool/main/n/${BPN}/${BPN}_${PV}.orig.tar.gz;name=archive \
  9. http://http.debian.net/debian/pool/main/n/${BPN}/${BPN}_${PV}-8.diff.gz;name=patch8 \
  10. file://rpc.rusersd-Makefile-fix-parallel-build-issue.patch \
  11. file://0001-Link-with-libtirpc.patch \
  12. "
  13. SRC_URI[archive.md5sum] = "dc99a80b9fde2ab427c874f88f1c1602"
  14. SRC_URI[archive.sha256sum] = "f00138651865ad2dcfec5dedda0cda403cb80c4ab68efcc3bbccafe198c24b6d"
  15. SRC_URI[patch8.md5sum] = "1ff498113e0f920d92088092e5570bdc"
  16. SRC_URI[patch8.sha256sum] = "14882dbdda4e37baa84d55b54b46c7e063a20fc9e04d1be1a2807643cd0f3067"
  17. CFLAGS += "-I${STAGING_INCDIR}/tirpc"
  18. EXTRA_OEMAKE = "RUSERSX=${STAGING_INCDIR}/rpcsvc/rusers.x"
  19. do_configure () {
  20. ./configure --prefix=${prefix} --installroot=${D} --with-c-compiler="${CC}"
  21. }
  22. do_install () {
  23. install -d ${D}${bindir}
  24. install -d ${D}${sbindir}
  25. install -d ${D}${mandir}/man1
  26. install -d ${D}${mandir}/man8
  27. install -d ${D}${sysconfdir}/xinetd.d
  28. sed -i 's/install -s/install/' rusers/Makefile
  29. sed -i 's/install -s/install/' rup/Makefile
  30. sed -i 's/install -s/install/' rpc.rusersd/Makefile
  31. oe_runmake 'INSTALLROOT=${D}' 'BINMODE=0755' \
  32. 'DAEMONMODE=0755' 'MANMODE=0644' \
  33. 'BINDIR=${bindir}' 'SBINDIR=${sbindir}' \
  34. 'MANDIR=${mandir}' install
  35. # create the xinetd config file
  36. cat >rusersd.conf <<EOF
  37. service rusersd
  38. {
  39. disable = yes
  40. type = RPC
  41. rpc_version = 1-2
  42. socket_type = dgram
  43. protocol = udp
  44. wait = yes
  45. user = root
  46. server = ${sbindir}/rpc.rusersd
  47. }
  48. EOF
  49. install rusersd.conf ${D}/${sysconfdir}/xinetd.d/rusersd
  50. }
  51. PACKAGES = "${PN}-client ${PN}-server ${PN}-doc ${BPN}-dbg"
  52. FILES_${PN}-client = "${bindir}/*"
  53. FILES_${PN}-server = "${sbindir}/* ${sysconfdir}"
  54. FILES_${PN}-doc = "${mandir}"
  55. FILES_${PN}-dbg = "${prefix}/src/debug \
  56. ${bindir}/.debug ${sbindir}/.debug"
  57. RDEPENDS_${PN}-server += "tcp-wrappers xinetd rpcbind"
  58. # http://errors.yoctoproject.org/Errors/Details/186962/
  59. COMPATIBLE_HOST_libc-musl = 'null'
  60. PNBLACKLIST[netkit-rusers] ?= "Fails to build rup.c:51:10: fatal error: rstat.h: No such file or directory"