Forráskód Böngészése

meta: do not prepend/append to BBCLASSEXTEND

Replace some "+=/=+" with "=" when setting BBCLASSEXTEND, they are
redundant and inconsistent with the same setting in other recipes.

Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Ming Liu 7 éve
szülő
commit
ebd31fd8d5

+ 1 - 1
meta-oe/recipes-connectivity/ser2net/ser2net_2.9.1.bb

@@ -12,4 +12,4 @@ SRC_URI[sha256sum] = "fdee1e69903cf409bdc6f32403a566cbc6006aa9e2a4d6f8f12b90dfd5
 
 inherit autotools pkgconfig
 
-BBCLASSEXTEND += "native nativesdk"
+BBCLASSEXTEND = "native nativesdk"

+ 1 - 1
meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb

@@ -165,4 +165,4 @@ FILES_${PN}-fstools = "\
     ${bindir}/mkuserimg \
 "
 
-BBCLASSEXTEND += "native"
+BBCLASSEXTEND = "native"

+ 1 - 1
meta-oe/recipes-devtools/json-spirit/json-spirit_4.08.bb

@@ -21,4 +21,4 @@ inherit cmake
 
 FILES_${PN}-dev += "${datadir}/cmake/Modules/FindLibJsonSpirit.cmake"
 
-BBCLASSEXTEND += "nativesdk"
+BBCLASSEXTEND = "nativesdk"

+ 1 - 1
meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb

@@ -45,4 +45,4 @@ PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'demos', '${PN}-demos', '', d
 FILES_${PN}-demos = "${bindir}/*"
 FILES_${PN}-dev += "${datadir}/cmake/Modules/FindLibRcf.cmake"
 
-BBCLASSEXTEND += "nativesdk"
+BBCLASSEXTEND = "nativesdk"

+ 1 - 1
meta-oe/recipes-devtools/log4cplus/log4cplus_1.2.0.bb

@@ -12,4 +12,4 @@ SRC_URI[sha256sum] = "ad5ec3b62f2f0bdc7f06fa398bde61091fd2493e91059e17315b519742
 
 inherit autotools pkgconfig
 
-BBCLASSEXTEND += "native"
+BBCLASSEXTEND = "native"

+ 1 - 1
meta-oe/recipes-extended/p7zip/p7zip_16.02.bb

@@ -36,4 +36,4 @@ EOF
     chmod 0755 ${D}${bindir}/7z
 }
 
-BBCLASSEXTEND += "native"
+BBCLASSEXTEND = "native"

+ 1 - 1
meta-oe/recipes-support/libssh2/libssh2_1.7.0.bb

@@ -23,4 +23,4 @@ PACKAGECONFIG ??= "openssl"
 PACKAGECONFIG[openssl] = "--with-openssl --with-libssl-prefix=${STAGING_LIBDIR},--without-openssl,openssl"
 PACKAGECONFIG[gcrypt] = "--with-libgcrypt --with-libgcrypt-prefix=${STAGING_EXECPREFIXDIR},--without-libgcrypt,libgcrypt"
 
-BBCLASSEXTEND += "native"
+BBCLASSEXTEND = "native"

+ 1 - 1
meta-oe/recipes-support/libtinyxml/libtinyxml_2.6.2.bb

@@ -42,4 +42,4 @@ do_install() {
     install -m 0644 ${S}/tinyxml.h ${D}${includedir}
 }
 
-BBCLASSEXTEND += "native"
+BBCLASSEXTEND = "native"

+ 1 - 1
meta-oe/recipes-support/lzip/lzip_1.16.bb

@@ -38,4 +38,4 @@ do_install () {
     fi
 }
 
-BBCLASSEXTEND += "native nativesdk"
+BBCLASSEXTEND = "native nativesdk"

+ 1 - 1
meta-python/recipes-devtools/python/python-setuptools-scm_1.15.0.bb

@@ -10,6 +10,6 @@ PYPI_PACKAGE = "setuptools_scm"
 RDEPENDS_${PN}_class-target = "python-py python-setuptools python-argparse python-debugger python-json"
 RDEPENDS_${PN}_class-native = "python-setuptools-native"
 
-BBCLASSEXTEND =+ "native"
+BBCLASSEXTEND = "native"
 
 inherit pypi setuptools

+ 1 - 1
meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.7.bb

@@ -24,4 +24,4 @@ inherit distutils
 RDEPENDS_${PN} += "python-stringold python-codecs python-math parted (>= 2.3)"
 RDEPENDS_${PN}_class-native = ""
 
-BBCLASSEXTEND += "native"
+BBCLASSEXTEND = "native"