p7zip_16.02.bb 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. SUMMARY = "7-zip is a commandline utility handling 7z archives."
  2. HOMEPAGE = "http://www.7-zip.org/"
  3. LICENSE = "LGPL-2.1+ & unRAR"
  4. LIC_FILES_CHKSUM = "file://DOC/copying.txt;md5=4fbd65380cdd255951079008b364516c \
  5. file://DOC/unRarLicense.txt;md5=9c87ddde469ef94aed153b0951d088de \
  6. file://DOC/License.txt;md5=879598edf1f54dddb6930d7581357f8b"
  7. SRC_URI = "http://downloads.sourceforge.net/p7zip/p7zip/${PV}/p7zip_${PV}_src_all.tar.bz2 \
  8. file://do_not_override_compiler_and_do_not_strip.patch"
  9. SRC_URI[md5sum] = "a0128d661cfe7cc8c121e73519c54fbf"
  10. SRC_URI[sha256sum] = "5eb20ac0e2944f6cb9c2d51dd6c4518941c185347d4089ea89087ffdd6e2341f"
  11. S = "${WORKDIR}/${BPN}_${PV}"
  12. do_install() {
  13. install -d ${D}${bindir}
  14. install -m 0755 ${S}/bin/* ${D}${bindir}
  15. }
  16. # all3: to build bin/7za, bin/7z (with its plugins), bin/7zr and bin/7zCon.sfx
  17. EXTRA_OEMAKE_class-native = "all3"
  18. do_install_class-native() {
  19. install -d ${D}${bindir}
  20. install -d ${D}${bindir}/Codecs
  21. install -m 0755 ${S}/bin/7* ${D}${bindir}
  22. install -m 0755 ${S}/bin/Codecs/* ${D}${bindir}/Codecs
  23. # Create a shell script wrapper to execute next to 7z.so
  24. mv ${D}${bindir}/7z ${D}${bindir}/7z.bin
  25. cat > ${D}${bindir}/7z << 'EOF'
  26. #!/bin/sh
  27. exec "$(dirname "$0")"/7z.bin "$@"
  28. EOF
  29. chmod 0755 ${D}${bindir}/7z
  30. }
  31. BBCLASSEXTEND = "native"