json-spirit_4.08.bb 785 B

123456789101112131415161718192021222324
  1. SUMMARY = "A C++ JSON Parser/Generator Implemented with Boost Spirit."
  2. DESCRIPTION = "JSON Spirit, a C++ library that reads and writes JSON files or streams. \
  3. It is written using the Boost Spirit parser generator. If you are \
  4. already using Boost, you can use JSON Spirit without any additional \
  5. dependencies."
  6. HOMEPAGE = "https://www.codeproject.com/kb/recipes/json_spirit.aspx"
  7. SECTION = "libs"
  8. PRIORITY = "optional"
  9. LICENSE = "MIT"
  10. LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=278ef6183dec4aae1524fccc4b0113c9"
  11. SRC_URI = "file://json_spirit_v${PV}.zip \
  12. file://0001-Adjust-the-cmake-files.patch \
  13. "
  14. S = "${WORKDIR}/json_spirit_v${PV}"
  15. DEPENDS = "boost"
  16. inherit cmake
  17. FILES_${PN}-dev += "${datadir}/cmake/Modules/FindLibJsonSpirit.cmake"
  18. BBCLASSEXTEND = "nativesdk"