浏览代码

musl-nscd: Add missing deps on flex and bison during build

Fix check for flex

Fails in do_compile at times see below

cp dist/src/nsswitch.yy.c obj/src/nsswitch.yy.c
cp: cannot create regular file 'obj/src/nsswitch.yy.c': No such file or directory
Makefile:78: recipe for target 'obj/src/nsswitch.yy.c' failed
make: *** [obj/src/nsswitch.yy.c] Error 1

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Armin Kuster <akuster808@gmail.com>
Khem Raj 3 年之前
父节点
当前提交
d67b8e191e

+ 29 - 0
meta-oe/recipes-devtools/musl/musl-nscd/0001-configure-Check-for-flex-if-lex-is-not-found.patch

@@ -0,0 +1,29 @@
+From 4d09032741475c4e9d3de62c8187597f3f72f934 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 22 Nov 2020 12:32:01 -0800
+Subject: [PATCH] configure: Check for flex if lex is not found
+
+lex is already checked by this time, therefore check should be to find
+flex
+Upstream-Status: Submitted [https://github.com/pikhq/musl-nscd/pull/12]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ configure | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure b/configure
+index 256824a..4c94568 100755
+--- a/configure
++++ b/configure
+@@ -249,7 +249,7 @@ printf "checking for lex... "
+ trylex ${CROSS_COMPILE}lex
+ trylex lex
+ trylex ${CROSS_COMPILE}flex
+-trylex lex
++trylex flex
+ printf "%s\n" "$LEX"
+ test -n "$LEX" || echo "$0: cannot find lex. Will try to use pre-provided source."
+ 
+-- 
+2.29.2
+

+ 3 - 0
meta-oe/recipes-devtools/musl/musl-nscd_git.bb

@@ -7,11 +7,14 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=9bf479a145bcaff8489e743da58afeee"
 SECTION = "utils"
 
+DEPENDS += "flex-native bison-native flex bison"
+
 PV = "1.0.2"
 
 SRCREV = "af581482a3e1059458f3c8b20a56f82807ca3bd4"
 SRC_URI = "git://github.com/pikhq/musl-nscd \
            file://0001-Fix-build-under-GCC-fno-common.patch \
+           file://0001-configure-Check-for-flex-if-lex-is-not-found.patch \
           "
 
 UPSTREAM_CHECK_COMMITS = "1"