Переглянути джерело

musl-nscd: Replace -fcommon with code patch

The patch fixes the need for -fcommon

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Armin Kuster <akuster808@gmail.com>
Khem Raj 3 роки тому
батько
коміт
bb956f0605

+ 43 - 0
meta-oe/recipes-devtools/musl/musl-nscd/0001-Fix-build-under-GCC-fno-common.patch

@@ -0,0 +1,43 @@
+From 8c0e4b7907eb577b1e5214f9a7bc75d5c3263b0a Mon Sep 17 00:00:00 2001
+From: Ariadne Conill <ariadne@dereferenced.org>
+Date: Sat, 14 Nov 2020 22:55:30 -0700
+Subject: [PATCH] Fix build under GCC -fno-common.
+
+Upstream-Status: Submitted [https://github.com/pikhq/musl-nscd/pull/11]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ include/modules.h | 4 ++--
+ src/main.c        | 3 +++
+ 2 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/include/modules.h b/include/modules.h
+index 70c1960..e77ec58 100644
+--- a/include/modules.h
++++ b/include/modules.h
+@@ -28,7 +28,7 @@ struct mod_passwd {
+ 	link_t link;
+ };
+ 
+-list_t passwd_mods;
+-list_t group_mods;
++extern list_t passwd_mods;
++extern list_t group_mods;
+ 
+ #endif
+diff --git a/src/main.c b/src/main.c
+index c1a78bb..808ef74 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -18,6 +18,9 @@
+ #include "parse.h"
+ #include "util.h"
+ 
++list_t passwd_mods;
++list_t group_mods;
++
+ static void *get_dll(const char *service)
+ {
+ 	char *path;
+-- 
+2.29.2
+

+ 3 - 3
meta-oe/recipes-devtools/musl/musl-nscd_git.bb

@@ -9,10 +9,10 @@ SECTION = "utils"
 
 PV = "1.0.2"
 
-CFLAGS += "-fcommon"
-
 SRCREV = "af581482a3e1059458f3c8b20a56f82807ca3bd4"
-SRC_URI = "git://github.com/pikhq/musl-nscd"
+SRC_URI = "git://github.com/pikhq/musl-nscd \
+           file://0001-Fix-build-under-GCC-fno-common.patch \
+          "
 
 UPSTREAM_CHECK_COMMITS = "1"