musl-nscd_git.bb 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright (C) 2020 Armin Kuster <akuster808@gmail.com>
  2. # Released under the MIT license (see COPYING.MIT for the terms)
  3. DESCRIPTION = "Musl-nscd is an implementation of the NSCD protocol, suitable for use with musl and with standard NSS modules"
  4. HOMEPAGE = "https://github.com/pikhq/musl-nscd"
  5. LICENSE = "MIT"
  6. LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=9bf479a145bcaff8489e743da58afeee"
  7. SECTION = "utils"
  8. DEPENDS += "flex-native bison-native flex bison"
  9. PV = "1.0.2"
  10. SRCREV = "af581482a3e1059458f3c8b20a56f82807ca3bd4"
  11. SRC_URI = "git://github.com/pikhq/musl-nscd \
  12. file://0001-Fix-build-under-GCC-fno-common.patch \
  13. file://0001-configure-Check-for-flex-if-lex-is-not-found.patch \
  14. "
  15. UPSTREAM_CHECK_COMMITS = "1"
  16. inherit autotools-brokensep
  17. S = "${WORKDIR}/git"
  18. do_configure () {
  19. # no debug set -s flag
  20. sed -i -e 's/LDFLAGS_AUTO=-s/LDFLAGS_AUTO=/' ${S}/configure
  21. ${S}/configure ${CONFIGUREOPTS} ${EXTRA_OECONF}
  22. }
  23. do_compile () {
  24. oe_runmake
  25. }
  26. do_install () {
  27. make DESTDIR=${D} install
  28. }
  29. COMPATIBLE_HOST = ".*-musl.*"