Browse Source

packagegroup: Add packagegroup-starfive-esssentials & packagegroup-starfive-dubhe-essentials
packagegroup-starfive-essentials contains basic packages needed by StarFive images.
packagegroup-starfive-dubhe-essentials contains basic packages needed by Starfive Dubhe series images.
Now all StarFive images uses packagegroup-starfive-essentials while StarFive Dubhe images uses packagegroup-starfive-dubhe-essentials.
Standardize the list of packages for installed by Dubhe series images.
Added parted package to core-image-minimal & core-image-starfive-extra.bb.

Signed-off-by: weiheng.cheng <weiheng.cheng@starfivetech.com>

weiheng.cheng 7 months ago
parent
commit
d87e5ee125

+ 3 - 10
recipes-core/images/core-image-minimal.bbappend

@@ -5,18 +5,11 @@ DEPENDS:starfive-visionfive2 += " opensbi starfive-tool-native"
 IMAGE_FEATURES += " allow-empty-password empty-root-password"
 
 IMAGE_INSTALL += " \
-	helloworld \
-	coremark \
-	dhrystone \
-	perf \
-	gdb \
-	gdbserver \
-	util-linux \
-	ethtool \
+	packagegroup-starfive-essentials \
 	bmap-tools \
 	systemd-analyze \
-	openssh \
 	e2fsprogs-resize2fs \
-	"
+	parted \
+        "
 
 EXTRA_IMAGEDEPENDS:starfive-visionfive2 += " alsa-lib libgpiod i2c-tools"

+ 18 - 24
recipes-core/images/core-image-starfive-extra.bb

@@ -4,30 +4,24 @@ require sd-image.inc
 
 DEPENDS += " opensbi u-boot-tools-native dtc-native"
 
-IMAGE_INSTALL = "packagegroup-core-boot \
-		${CORE_IMAGE_EXTRA_INSTALL} \
-		helloworld \
-        	coremark \
-        	dhrystone \
-        	perf \
-        	gdb \
-        	gdbserver \
-        	util-linux \
-        	ethtool \
-        	bmap-tools \
-        	systemd-analyze \
-        	openssh \
-        	e2fsprogs-resize2fs \
-		ldd \
-		file \
-		git \
-		texinfo \
-		libcheck \
-		packagegroup-core-buildessential \
-		packagegroup-starfive-c \
-		nodejs \
-        	nodejs-npm \
-		"
+IMAGE_INSTALL = "\
+	packagegroup-core-boot \
+	${CORE_IMAGE_EXTRA_INSTALL} \
+	bmap-tools \
+	systemd-analyze \
+	e2fsprogs-resize2fs \
+	parted \
+	ldd \
+	file \
+	git \
+	texinfo \
+	libcheck \
+	packagegroup-core-buildessential \
+	packagegroup-starfive-c \
+	packagegroup-starfive-essentials \
+	nodejs \
+	nodejs-npm \
+	"
 
 IMAGE_LINGUAS = " "
 

+ 10 - 1
recipes-core/images/dubhe-image-essential.inc

@@ -8,4 +8,13 @@ IMAGE_ROOTFS_SIZE ?= "8192"
 IMAGE_FEATURES += "allow-empty-password empty-root-password"
 IMAGE_FEATURES:remove = "dbg-pkgs"
 
-IMAGE_INSTALL += "mtd-utils helloworld coremark dhrystone perf util-linux btrfs-tools parted lrzsz devmem2 iperf3 e2fsprogs ethtool"
+IMAGE_INSTALL += "\
+	packagegroup-starfive-essentials \
+	packagegroup-starfive-dubhe-essentials \
+	mtd-utils \
+	btrfs-tools \
+	parted \
+	lrzsz \
+	devmem2 \
+	e2fsprogs \
+	"

+ 12 - 4
recipes-core/images/dubhe-image-initramfs.bb

@@ -4,10 +4,18 @@ the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
 first 'init' program more efficiently."
 
 INITRAMFS_SCRIPTS ?= "\
-                      initramfs-boot packagegroup-core-boot \
-                     "
-PACKAGE_INSTALL = "${INITRAMFS_SCRIPTS} ${VIRTUAL-RUNTIME_base-utils} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} helloworld coremark dhrystone perf gdb gdbserver util-linux ethtool atftp iperf3 openssh dhcpcd kvmtool tmux"
-
+	initramfs-boot \
+	packagegroup-core-boot \
+	"
+
+PACKAGE_INSTALL = "\
+	${INITRAMFS_SCRIPTS} \
+	${VIRTUAL-RUNTIME_base-utils} \
+	base-passwd \
+	${ROOTFS_BOOTSTRAP_INSTALL} \
+	packagegroup-starfive-essentials \
+	packagegroup-starfive-dubhe-essentials \
+	"
 
 # Do not pollute the initrd image with rootfs features
 IMAGE_FEATURES = ""

+ 1 - 1
recipes-core/images/dubhe-image-minimal_0.1.bb

@@ -14,7 +14,7 @@ require dubhe-image-essential.inc
 
 export IMAGE_BASENAME = "console-image-minimal"
 
-do_image_qspi_ext4[depends] += " \
+do_image_qspi_ext4[depends] += "\
 	deploy-bootfiles:do_deploy \
 	opensbi:do_deploy \
 	virtual/kernel:do_deploy \

+ 5 - 3
recipes-core/images/qspi-image_0.1.bb

@@ -11,9 +11,11 @@ LIC_FILES_CHKSUM = ""
 IMAGE_FSTYPES = "qspi"
 
 do_rootfs[depends] += "dubhe-image-initramfs:do_rootfs"
-do_image[depends] += " deploy-bootfiles:do_deploy"
-do_image[depends] += " opensbi:do_deploy"
-do_image[depends] += " virtual/kernel:do_deploy"
+do_image[depends] += "\
+	deploy-bootfiles:do_deploy \
+	opensbi:do_deploy \
+	virtual/kernel:do_deploy \
+	"
 
 IMAGE_CMD:qspi () {
 	dd if=${DEPLOY_DIR_IMAGE}/bootcode.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-initramfs-image.bin bs=32 seek=0 count=128

+ 5 - 1
recipes-core/images/qspi-nfs-essential.inc

@@ -8,4 +8,8 @@ IMAGE_ROOTFS_SIZE ?= "8192"
 IMAGE_FEATURES += "allow-empty-password empty-root-password"
 IMAGE_FEATURES:remove = "dbg-pkgs"
 
-IMAGE_INSTALL += "mtd-utils helloworld coremark dhrystone perf util-linux"
+IMAGE_INSTALL += "\
+	packagegroup-starfive-essentials \
+	packagegroup-starfive-dubhe-essentials \
+	mtd-utils \
+	"

+ 1 - 1
recipes-core/images/qspi-nfs-image_0.1.bb

@@ -24,7 +24,7 @@ export IMAGE_BASENAME = "nfs-rootfs"
 #	rm ${IMAGE_ROOTFS}/var/log; mkdir -p ${IMAGE_ROOTFS}/var/log; touch ${IMAGE_ROOTFS}/var/log/lighttpd
 #}
 
-do_image_qspi_nfs[depends] += " \
+do_image_qspi_nfs[depends] += "\
 	deploy-bootfiles:do_deploy \
 	opensbi:do_deploy \
 	virtual/kernel:do_deploy \

+ 5 - 2
recipes-core/images/qspi-ubifs-image_0.1.bb

@@ -17,12 +17,15 @@ IMAGE_ROOTFS_SIZE ?= "8192"
 IMAGE_FEATURES += "allow-empty-password empty-root-password"
 
 #IMAGE_INSTALL += "mtd-utils mtd-utils-ubifs kernel-modules"
-IMAGE_INSTALL += "helloworld"
+IMAGE_INSTALL += "\
+	packagegroup-starfive-essentials \
+	packagegroup-starfive-dubhe-essentials \
+	"
 
 IMAGE_FEATURES:remove = "dbg-pkgs"
 
 export IMAGE_BASENAME = "qspi-ubifs"
-do_image_qspi_ubifs[depends] += " \
+do_image_qspi_ubifs[depends] += "\
 	deploy-bootfiles:do_deploy \
 	opensbi:do_deploy \
 	virtual/kernel:do_deploy \

+ 13 - 0
recipes-core/packagegroups/packagegroup-starfive-dubhe-essentials.bb

@@ -0,0 +1,13 @@
+SUMMARY = "Packages required by StarFive Dubhe"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit packagegroup
+
+RDEPENDS:${PN} = "\
+	atftp \
+	iperf3 \
+	dhcpcd \
+	kvmtool \
+	tmux \
+	"

+ 18 - 0
recipes-core/packagegroups/packagegroup-starfive-essentials.bb

@@ -0,0 +1,18 @@
+SUMMARY = "Essential Packages for StarFive Images."
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit packagegroup
+
+RDEPENDS:${PN} = "\
+	helloworld \
+	coremark \
+	dhrystone \
+	perf \
+	gdb \
+	gdbserver \
+	util-linux \
+	ethtool \
+	openssh \
+	"
+