Переглянути джерело

dubhe: linux-starfive-dev: Fix eSDK .dts syntax error
echo -e "xxx" is parsed as echo"-e xxx" in eSDK if the sstate cache from bitbake is not used.
Meaning if were to "devtool modify linux-starfive-dev" followed by building linux-starfive-dev will get do_compile error due to .dts syntax error.

Signed-off-by: weiheng.cheng <weiheng.cheng@starfivetech.com>

weiheng.cheng 7 місяців тому
батько
коміт
0688d19413
1 змінених файлів з 5 додано та 5 видалено
  1. 5 5
      recipes-kernel/linux/linux-starfive-dev_6.1.20.bb

+ 5 - 5
recipes-kernel/linux/linux-starfive-dev_6.1.20.bb

@@ -59,11 +59,11 @@ do_configure:append:starfive-dubhe() {
 		if [ "$dts_file" = "${S}/arch/riscv/boot/dts/starfive/dubhe90_fpga_dual.dts" ]; then
 			continue
 		fi
-		echo -e "/ {" >> "$dts_file"
-		echo -e "\tchosen {" >> "$dts_file"
-		echo -e "\t\tbootargs" >> "$dts_file"
-		echo -e "\t};" >> "$dts_file"
-		echo -e "};" >> "$dts_file"
+		echo "/ {" >> "$dts_file"
+		echo "    chosen {" >> "$dts_file"
+		echo "        bootargs" >> "$dts_file"
+		echo "    };" >> "$dts_file"
+		echo "};" >> "$dts_file"
 	done
 
 	sed -i "s+bootargs+bootargs = \"${BOOTARGS_EXT4}\";+g" ${S}/arch/riscv/boot/dts/starfive/dubhe*0_fpga_ext4.dts