dubhe-image-initramfs.bb 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Simple initramfs image. Mostly used for live images.
  2. DESCRIPTION = "Small image capable of booting a device. The kernel includes \
  3. the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
  4. first 'init' program more efficiently."
  5. INITRAMFS_SCRIPTS ?= "\
  6. initramfs-boot \
  7. packagegroup-core-boot \
  8. "
  9. PACKAGE_INSTALL = "\
  10. ${INITRAMFS_SCRIPTS} \
  11. ${VIRTUAL-RUNTIME_base-utils} \
  12. base-passwd \
  13. ${ROOTFS_BOOTSTRAP_INSTALL} \
  14. packagegroup-starfive-essentials \
  15. packagegroup-starfive-dubhe-essentials \
  16. "
  17. # Do not pollute the initrd image with rootfs features
  18. IMAGE_FEATURES = ""
  19. export IMAGE_BASENAME = "dubhe-image-initramfs"
  20. IMAGE_NAME_SUFFIX ?= ""
  21. IMAGE_LINGUAS = "en-us"
  22. GLIBC_GENERATE_LOCALES = "en_US.UTF-8"
  23. LICENSE = "MIT"
  24. IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
  25. inherit core-image
  26. IMAGE_ROOTFS_SIZE = "8192"
  27. IMAGE_ROOTFS_EXTRA_SPACE = "0"
  28. EXTRA_IMAGEDEPENDS ?= ""
  29. # Use the same restriction as initramfs-module-install
  30. COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*|riscv64.*|rv64.*)-(linux.*|freebsd.*)'
  31. # Override this as the qspi-image will populate the sdk_ext
  32. do_populate_sdk_ext () {
  33. }