Browse Source

packagegroup: Add packagegroup-starfive-toolchain
This packagegroup contains packages needed by StarFive toolchain.

Signed-off-by: weiheng.cheng <weiheng.cheng@starfivetech.com>

weiheng.cheng 6 months ago
parent
commit
9bd28c6dc5

+ 1 - 1
recipes-core/images/core-image-minimal.bbappend

@@ -12,4 +12,4 @@ IMAGE_INSTALL += " \
 	parted \
         "
 
-EXTRA_IMAGEDEPENDS:starfive-visionfive2 += " alsa-lib libgpiod i2c-tools"
+TOOLCHAIN_TARGET_TASK += "packagegroup-starfive-toolchain"

+ 2 - 0
recipes-core/images/core-image-starfive-extra.bb

@@ -23,6 +23,8 @@ IMAGE_INSTALL = "\
 	nodejs-npm \
 	"
 
+TOOLCHAIN_TARGET_TASK += "packagegroup-starfive-toolchain"
+
 IMAGE_LINGUAS = " "
 
 LICENSE = "MIT"

+ 2 - 0
recipes-core/images/dubhe-image-essential.inc

@@ -18,3 +18,5 @@ IMAGE_INSTALL += "\
 	devmem2 \
 	e2fsprogs \
 	"
+
+TOOLCHAIN_TARGET_TASK += "packagegroup-starfive-toolchain"

+ 2 - 0
recipes-core/images/dubhe-image-initramfs.bb

@@ -17,6 +17,8 @@ PACKAGE_INSTALL = "\
 	packagegroup-starfive-dubhe-essentials \
 	"
 
+TOOLCHAIN_TARGET_TASK += "packagegroup-starfive-toolchain"
+
 # Do not pollute the initrd image with rootfs features
 IMAGE_FEATURES = ""
 

+ 2 - 0
recipes-core/images/qspi-nfs-essential.inc

@@ -13,3 +13,5 @@ IMAGE_INSTALL += "\
 	packagegroup-starfive-dubhe-essentials \
 	mtd-utils \
 	"
+
+TOOLCHAIN_TARGET_TASK += "packagegroup-starfive-toolchain"

+ 2 - 0
recipes-core/images/qspi-ubifs-image_0.1.bb

@@ -22,6 +22,8 @@ IMAGE_INSTALL += "\
 	packagegroup-starfive-dubhe-essentials \
 	"
 
+TOOLCHAIN_TARGET_TASK += "packagegroup-starfive-toolchain"
+
 IMAGE_FEATURES:remove = "dbg-pkgs"
 
 export IMAGE_BASENAME = "qspi-ubifs"

+ 14 - 0
recipes-core/packagegroups/packagegroup-starfive-toolchain.bb

@@ -0,0 +1,14 @@
+SUMMARY = "Packages required for StarFive toolchain"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit packagegroup
+
+RDEPENDS:${PN} = "\
+	glibc glibc-dev glibc-staticdev \
+	libgomp libgomp-dev libgomp-staticdev \
+	alsa-lib alsa-lib-dev \
+	libgpiod libgpiod-dev \
+	i2c-tools i2c-tools-dev i2c-tools-staticdev \
+	libatomic-ops libatomic-ops-dev libatomic-ops-staticdev \
+	"