core-image-starfive-extra.bb 698 B

1234567891011121314151617181920212223242526272829303132333435
  1. SUMMARY = "A StarFive image with additional packages."
  2. require sd-image.inc
  3. DEPENDS += " opensbi u-boot-tools-native dtc-native"
  4. IMAGE_INSTALL = "\
  5. packagegroup-core-boot \
  6. ${CORE_IMAGE_EXTRA_INSTALL} \
  7. bmap-tools \
  8. systemd-analyze \
  9. e2fsprogs-resize2fs \
  10. parted \
  11. ldd \
  12. file \
  13. git \
  14. texinfo \
  15. libcheck \
  16. packagegroup-core-buildessential \
  17. packagegroup-starfive-c \
  18. packagegroup-starfive-essentials \
  19. nodejs \
  20. nodejs-npm \
  21. "
  22. TOOLCHAIN_TARGET_TASK += "packagegroup-starfive-toolchain"
  23. IMAGE_LINGUAS = " "
  24. LICENSE = "MIT"
  25. inherit core-image
  26. IMAGE_ROOTFS_SIZE ?= "8192"
  27. IMAGE_ROOTFS_EXTRA_SPACE:append = "${@bb.utils.contains("DISTRO_FEATURES", "systemd", " + 4096", "", d)}"