Ver código fonte

package/eudev: fix install command

The directory $(TARGET_DIR)/etc/init.d/ must exist before installing
S10udev init script.
Add the missing "-D" option to create the "init.d" directory.

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
(cherry picked from commit 1037475b9b9e1ec8092e4f90c3e33f9c485867ff)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Romain Naour 8 anos atrás
pai
commit
ccda2ae98d
1 arquivos alterados com 1 adições e 1 exclusões
  1. 1 1
      package/eudev/eudev.mk

+ 1 - 1
package/eudev/eudev.mk

@@ -57,7 +57,7 @@ EUDEV_CONF_OPTS += --disable-selinux
 endif
 
 define EUDEV_INSTALL_INIT_SYSV
-	$(INSTALL) -m 0755 package/eudev/S10udev $(TARGET_DIR)/etc/init.d/S10udev
+	$(INSTALL) -D -m 0755 package/eudev/S10udev $(TARGET_DIR)/etc/init.d/S10udev
 endef
 
 # Required by default rules for input devices