Browse Source

package/pkg-kernel-module.mk: module build fails

Observed the following when building cryptodev-linux:
>>> cryptodev-linux 1.7 Building kernel module(s)
grep: /.config: No such file or directory
ERROR: Kernel does not support loadable modules

Fix LINUX_DIR reference when determining if kernel configuration
supports loadable modules.

Signed-off-by: Doug Kehn <rdkehn@yahoo.com>
Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Doug Kehn 8 years ago
parent
commit
16768877e3
1 changed files with 1 additions and 1 deletions
  1. 1 1
      package/pkg-kernel-module.mk

+ 1 - 1
package/pkg-kernel-module.mk

@@ -60,7 +60,7 @@ $(2)_MODULE_SUBDIRS ?= .
 # includes and other support files (Booo!)
 define $(2)_KERNEL_MODULES_BUILD
 	@$$(call MESSAGE,"Building kernel module(s)")
-	@if ! grep -Fqx 'CONFIG_MODULES=y' $(LINUX_DIR)/.config; then \
+	@if ! grep -Fqx 'CONFIG_MODULES=y' $$(LINUX_DIR)/.config; then \
 		echo "ERROR: Kernel does not support loadable modules"; \
 		exit 1; \
 	fi