Browse Source

yaboot: drop support

Yaboot does not build, hasn't been updated since a long time, and
isn't very common these days on embedded PowerPC platforms.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thomas Petazzoni 14 years ago
parent
commit
afd77256c9
3 changed files with 0 additions and 50 deletions
  1. 0 1
      boot/Config.in
  2. 0 5
      boot/yaboot/Config.in
  3. 0 44
      boot/yaboot/yaboot.mk

+ 0 - 1
boot/Config.in

@@ -3,7 +3,6 @@ menu "Bootloaders"
 source "boot/grub/Config.in"
 source "boot/grub2/Config.in"
 source "boot/syslinux/Config.in"
-source "boot/yaboot/Config.in"
 source "boot/u-boot/Config.in"
 source "boot/at91bootstrap/Config.in"
 source "boot/at91dataflashboot/Config.in"

+ 0 - 5
boot/yaboot/Config.in

@@ -1,5 +0,0 @@
-config BR2_TARGET_YABOOT
-	bool "yaboot"
-	depends on BR2_powerpc
-	help
-	  The yaboot bootloader for new world powerpc systems.

+ 0 - 44
boot/yaboot/yaboot.mk

@@ -1,44 +0,0 @@
-ifeq ($(ARCH),powerpc)
-
-#############################################################
-#
-# yaboot
-#
-#############################################################
-
-YABOOT_SOURCE:=yaboot-1.3.13.tar.gz
-YABOOT_SITE:=http://penguinppc.org/bootloaders/yaboot
-YABOOT_DIR:=$(BUILD_DIR)/yaboot-1.3.13
-
-$(DL_DIR)/$(YABOOT_SOURCE):
-	 $(call DOWNLOAD,$(YABOOT_SITE),$(YABOOT_SOURCE))
-
-yaboot-source: $(DL_DIR)/$(YABOOT_SOURCE)
-
-$(YABOOT_DIR)/Makefile: $(DL_DIR)/$(YABOOT_SOURCE)
-	$(ZCAT) $(DL_DIR)/$(YABOOT_SOURCE) | tar -C $(BUILD_DIR) -xvf -
-	touch -c $(YABOOT_DIR)/Makefile
-
-$(YABOOT_DIR)/second/yaboot: $(YABOOT_DIR)/Makefile
-	$(MAKE) -C $(YABOOT_DIR) CROSS=$(TARGET_CROSS)
-	touch -c $(YABOOT_DIR)/second/yaboot
-
-yaboot: $(YABOOT_DIR)/second/yaboot
-
-yaboot-clean:
-	$(MAKE) -C $(YABOOT_DIR) clean
-
-yaboot-dirclean:
-	rm -rf $(YABOOT_DIR)
-
-endif
-
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_TARGET_YABOOT),y)
-TARGETS+=yaboot
-endif
-