浏览代码

bootloaders: move bootloader build code to boot/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thomas Petazzoni 14 年之前
父节点
当前提交
649b5b9250

+ 2 - 0
Config.in

@@ -293,4 +293,6 @@ source "package/Config.in"
 
 source "fs/Config.in"
 
+source "boot/Config.in"
+
 source "target/Config.in"

+ 2 - 1
Makefile

@@ -320,8 +320,9 @@ ifeq ($(BR2_ENABLE_LOCALE_PURGE),y)
 TARGETS+=target-purgelocales
 endif
 
-# target stuff is last so it can override anything else
+include boot/common.mk
 include target/Makefile.in
+include fs/common.mk
 
 TARGETS+=erase-fakeroots
 

+ 12 - 0
boot/Config.in

@@ -0,0 +1,12 @@
+menu "Bootloaders"
+
+source "boot/grub/Config.in"
+source "boot/grub2/Config.in"
+source "boot/syslinux/Config.in"
+source "boot/yaboot/Config.in"
+source "boot/u-boot/Config.in"
+source "boot/at91bootstrap/Config.in"
+source "boot/at91dataflashboot/Config.in"
+
+endmenu
+

+ 2 - 3
target/device/Atmel/at91bootstrap/Config.in → boot/at91bootstrap/Config.in

@@ -1,7 +1,6 @@
 menuconfig BR2_TARGET_AT91BOOTSTRAP
-	depends on BR2_TARGET_AT91SAM9260EK || BR2_TARGET_AT91SAM9260DFC || BR2_TARGET_AT91SAM9260PF || \
-	BR2_TARGET_AT91SAM9261EK || BR2_TARGET_AT91SAM9263EK || BR2_TARGET_AT91SAM9XEEK || BR2_TARGET_AT91SAM9G20DFC
-	bool "Build AT91 Bootstrap for selected chip"
+	depends on BR2_arm
+	bool "AT91 Bootstrap"
 
 if	BR2_TARGET_AT91BOOTSTRAP
 

+ 1 - 1
target/device/Atmel/at91bootstrap/at91bootstrap.mk → boot/at91bootstrap/at91bootstrap.mk

@@ -39,7 +39,7 @@ $(DL_DIR)/$(AT91BOOTSTRAP_SOURCE):
 $(AT91BOOTSTRAP_DIR)/.unpacked: $(DL_DIR)/$(AT91BOOTSTRAP_SOURCE)
 	mkdir -p $(BUILD_DIR)
 	$(AT91BOOTSTRAP_ZCAT) $(DL_DIR)/$(AT91BOOTSTRAP_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-	toolchain/patch-kernel.sh $(AT91BOOTSTRAP_DIR) target/device/Atmel/at91bootstrap/ at91bootstrap-$(AT91BOOTSTRAP_VERSION)\*.patch
+	toolchain/patch-kernel.sh $(AT91BOOTSTRAP_DIR) boot/at91bootstrap/ at91bootstrap-$(AT91BOOTSTRAP_VERSION)\*.patch
 	touch $(AT91BOOTSTRAP_DIR)/.unpacked
 
 $(AT91BOOTSTRAP_DIR)/.configured: $(AT91BOOTSTRAP_DIR)/.unpacked .config

+ 3 - 3
target/device/Atmel/DataFlashBoot/Config.in → boot/at91dataflashboot/Config.in

@@ -1,6 +1,6 @@
-config BR2_TARGET_DATAFLASHBOOT
-       depends on BR2_TARGET_AT91RM9200 || BR2_TARGET_AT91SAM9261 || BR2_TARGET_AT91SAM9261S
-	bool "Build Dataflashboot for selected chip"
+menuconfig BR2_TARGET_DATAFLASHBOOT
+       depends on BR2_arm
+       bool "AT91 DataFlashBoot"
 
 choice
 	prompt "Target Architecture"

+ 0 - 0
target/device/Atmel/DataFlashBoot/DataflashBoot.mk → boot/at91dataflashboot/at91dataflashboot.mk


+ 1 - 0
boot/common.mk

@@ -0,0 +1 @@
+include boot/*/*.mk

+ 0 - 0
target/x86/grub/Config.in → boot/grub/Config.in


+ 0 - 0
target/x86/grub/grub.100-autoreconf.patch → boot/grub/grub.100-autoreconf.patch


+ 0 - 0
target/x86/grub/grub.200-fix_mbr_handling.patch → boot/grub/grub.200-fix_mbr_handling.patch


+ 0 - 0
target/x86/grub/grub.300-honor_UCLIBC_HAS_LFS.patch → boot/grub/grub.300-honor_UCLIBC_HAS_LFS.patch


+ 0 - 0
target/x86/grub/grub.400-nic_update2.patch.bz2 → boot/grub/grub.400-nic_update2.patch.bz2


+ 1 - 1
target/x86/grub/grub.mk → boot/grub/grub.mk

@@ -75,7 +75,7 @@ $(GRUB_DIR)/.unpacked: $(DL_DIR)/$(GRUB_SOURCE) $(DL_DIR)/$(GRUB_PATCH)
 	for i in `grep -v "^#" $(GRUB_DIR)/debian/patches/00list`; do \
 		cat $(GRUB_DIR)/debian/patches/$$i | patch -p1 -d $(GRUB_DIR); \
 	done
-	toolchain/patch-kernel.sh $(GRUB_DIR) target/x86/grub grub.\*.patch{,.bz2}
+	toolchain/patch-kernel.sh $(GRUB_DIR) boot/grub grub.\*.patch{,.bz2}
 	touch $@
 
 $(GRUB_DIR)/.configured: $(GRUB_DIR)/.unpacked

+ 0 - 0
target/x86/grub/menu.lst → boot/grub/menu.lst


+ 0 - 0
target/x86/grub/splash.xpm.gz → boot/grub/splash.xpm.gz


+ 0 - 0
target/x86/grub2/Config.in → boot/grub2/Config.in


+ 0 - 0
target/x86/grub2/grub-1.95-001-fix-grub-install.patch → boot/grub2/grub-1.95-001-fix-grub-install.patch


+ 1 - 1
target/x86/grub2/grub2.mk → boot/grub2/grub2.mk

@@ -75,7 +75,7 @@ $(GRUB2_DIR)/.unpacked: $(DL_DIR)/$(GRUB2_SOURCE) $(DL_DIR)/$(GRUB2_PATCH)
 	for i in `grep -v "^#" $(GRUB2_DIR)/debian/patches/00list`; do \
 		cat $(GRUB2_DIR)/debian/patches/$$i | patch -p1 -d $(GRUB2_DIR); \
 	done
-	toolchain/patch-kernel.sh $(GRUB2_DIR) target/x86/grub2 grub-\*.patch
+	toolchain/patch-kernel.sh $(GRUB2_DIR) boot/grub2 grub-\*.patch
 	touch $@
 
 $(GRUB2_DIR)/.configured: $(GRUB2_DIR)/.unpacked

+ 0 - 0
target/x86/syslinux/Config.in → boot/syslinux/Config.in


+ 0 - 0
target/x86/syslinux/syslinux-3.82-makefile.patch → boot/syslinux/syslinux-3.82-makefile.patch


+ 1 - 1
target/x86/syslinux/syslinux.mk → boot/syslinux/syslinux.mk

@@ -38,7 +38,7 @@ syslinux-source: $(DL_DIR)/$(SYSLINUX_SOURCE)
 
 $(SYSLINUX_DIR)/Makefile: $(DL_DIR)/$(SYSLINUX_SOURCE) $(SYSLINUX_PATCH)
 	$(SYSLINUX_CAT) $(DL_DIR)/$(SYSLINUX_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-	toolchain/patch-kernel.sh $(SYSLINUX_DIR) target/x86/syslinux/ \*.patch
+	toolchain/patch-kernel.sh $(SYSLINUX_DIR) boot/syslinux/ \*.patch
 	touch -c $@
 
 $(SYSLINUX_DIR)/isolinux.bin $(SYSLINUX_DIR)/pxelinux.bin: $(SYSLINUX_DIR)/Makefile

+ 0 - 0
target/u-boot/Config.in → boot/u-boot/Config.in


+ 1 - 1
target/u-boot/Makefile.in → boot/u-boot/Makefile.in

@@ -70,7 +70,7 @@ $(U_BOOT_DIR)/.unpacked: $(DL_DIR)/$(U_BOOT_SOURCE)
 	touch $@
 
 $(U_BOOT_DIR)/.patched: $(U_BOOT_DIR)/.unpacked
-	toolchain/patch-kernel.sh $(U_BOOT_DIR) target/u-boot \
+	toolchain/patch-kernel.sh $(U_BOOT_DIR) boot/u-boot \
 		u-boot-$(U_BOOT_VERSION)-\*.patch \
 		u-boot-$(U_BOOT_VERSION)-\*.patch.$(ARCH)
 ifneq ($(strip $(U_BOOT_ARCH_PATCH_DIR)),)

+ 0 - 0
target/u-boot/u-boot-2009.01-include_asm-avr32_io.h.patch.avr32 → boot/u-boot/u-boot-2009.01-include_asm-avr32_io.h.patch.avr32


+ 0 - 0
target/powerpc/yaboot/Config.in → boot/yaboot/Config.in


+ 0 - 0
target/powerpc/yaboot/yaboot.mk → boot/yaboot/yaboot.mk


+ 0 - 9
target/Config.in

@@ -1,12 +1,3 @@
-menu "Bootloaders"
-
-source "target/x86/grub/Config.in"
-#source "target/x86/grub2/Config.in"
-source "target/x86/syslinux/Config.in"
-source "target/powerpc/yaboot/Config.in"
-source "target/u-boot/Config.in"
-endmenu
-
 menu "Kernel"
 choice
 	prompt "Kernel type"

+ 0 - 8
target/Makefile.in

@@ -54,16 +54,8 @@ include target/generic/Makefile.in
 
 # this eventually adds the kernel target to TARGETS:
 include target/device/Makefile.in
-include target/x86/Makefile.in
-include target/powerpc/Makefile.in
 include target/xtensa/Makefile.in
 
-ifeq ($(BR2_TARGET_UBOOT),y)
-include target/u-boot/Makefile.in
-endif
-
-include fs/common.mk
-
 # kernel rules
 # We already did add the kernel target to TARGETS and now just pull in the rules
 # to actually build this target.

+ 0 - 4
target/device/Atmel/Config.in

@@ -66,8 +66,4 @@ config BR2_BOARD_PATH
 
 endmenu
 
-source "target/device/Atmel/DataFlashBoot/Config.in"
-
-source "target/device/Atmel/at91bootstrap/Config.in"
-
 endif

+ 0 - 12
target/device/Atmel/Makefile.in

@@ -66,18 +66,6 @@ include target/device/Atmel/*/Makefile.in
 UBOOT_CONFIG:=$(UBOOT_BOARD_NAME)_config
 UBOOT_CONFIG_FILE:=$(BOARD_PATH)/u-boot/$(UBOOT_BOARD_NAME).h
 
-#ifeq ($(BR2_TARGET_UBOOT_AT91),y)
-#include $(ATMEL_PATH)/u-boot/u-boot.mk
-#endif
-
-ifeq ($(BR2_TARGET_DATAFLASHBOOT),y)
-include $(ATMEL_PATH)/DataFlashBoot/DataflashBoot.mk
-endif
-
-ifeq ($(BR2_TARGET_AT91BOOTSTRAP),y)
-include $(ATMEL_PATH)/at91bootstrap/at91bootstrap.mk
-endif
-
 atmel_status:
 	@echo BUILD_DIR=$(BUILD_DIR)
 	@echo BOARD_NAME=$(BOARD_NAME)

+ 0 - 1
target/powerpc/Makefile.in

@@ -1 +0,0 @@
-include target/powerpc/*/*.mk

+ 0 - 3
target/x86/Makefile.in

@@ -1,3 +0,0 @@
-ifeq ($(BR2_i386),y)
-include target/x86/*/*.mk
-endif