Kaynağa Gözat

cups: fix libdir handling

Cups uses /usr/lib64 if the HOST has it, no matter if it is cross compiling
for a 32bit arch, breaking the build for stuff looking in /usr/lib.

The fix of commit edd2716c didn't work, it would just force /usr/lib64 if
the target is 64 bit.  Instead, force installation in /usr/lib regardless
of the host.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Arnout Vandecappelle 12 yıl önce
ebeveyn
işleme
7655b95e27
1 değiştirilmiş dosya ile 1 ekleme ve 1 silme
  1. 1 1
      package/cups/cups.mk

+ 1 - 1
package/cups/cups.mk

@@ -14,7 +14,7 @@ CUPS_CONF_OPT = --without-perl \
 		--without-java \
 		--disable-gnutls \
 		--disable-gssapi \
-		--libdir=/usr/$(if $(BR2_ARCH_IS_64),lib64,lib)
+		--libdir=/usr/lib
 
 CUPS_DEPENDENCIES = $(if $(BR2_PACKAGE_ZLIB),zlib) \
 		    $(if $(BR2_PACKAGE_LIBPNG),libpng) \