瀏覽代碼

links: Enable graphics for X11

Graphics can be enabled for X11 as well.
Do not select DirectFB for graphics,
set DirectFB or X11 dependencies instead.

Signed-off-by: Valentine Barshak <gvaxon@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Valentine Barshak 11 年之前
父節點
當前提交
3c592cb4df
共有 2 個文件被更改,包括 17 次插入6 次删除
  1. 4 4
      package/links/Config.in
  2. 13 2
      package/links/links.mk

+ 4 - 4
package/links/Config.in

@@ -6,10 +6,10 @@ config BR2_PACKAGE_LINKS
 	  http://links.twibright.com/
 
 config BR2_PACKAGE_LINKS_GRAPHICS
-	bool "use graphics (directfb)"
-	depends on BR2_PACKAGE_LINKS
-	select BR2_PACKAGE_DIRECTFB
+	bool "use graphics"
+	depends on BR2_PACKAGE_LINKS && (BR2_PACKAGE_DIRECTFB || BR2_PACKAGE_XORG7)
+	select BR2_PACKAGE_XLIB_LIBXT if BR2_PACKAGE_XORG7
 	select BR2_PACKAGE_LIBPNG
 	help
-	  Enable graphics output.
+	  Enable graphics output for DirectFB or X11.
 	  Otherwise links will be text-mode only.

+ 13 - 2
package/links/links.mk

@@ -6,13 +6,24 @@
 
 LINKS_VERSION = 2.5
 LINKS_SITE = http://links.twibright.com/download
-LINKS_CONF_OPT = --without-x
 LINKS_DEPENDENCIES = host-pkgconf
 
 ifeq ($(BR2_PACKAGE_LINKS_GRAPHICS),y)
 LINKS_CONF_OPT += --enable-graphics
+LINKS_DEPENDENCIES += libpng
+ifeq ($(BR2_PACKAGE_XLIB_LIBXT),y)
+LINKS_CONF_OPT += --with-x
+LINKS_DEPENDENCIES += xlib_libXt
+else
+LINKS_CONF_OPT += --without-x
+endif
+ifeq ($(BR2_PACKAGE_DIRECTFB),y)
 LINKS_CONF_ENV = ac_cv_path_DIRECTFB_CONFIG=$(STAGING_DIR)/usr/bin/directfb-config
-LINKS_DEPENDENCIES += directfb libpng
+LINKS_CONF_OPT += --with-directfb
+LINKS_DEPENDENCIES += directfb
+else
+LINKS_CONF_OPT += --without-directfb
+endif
 ifeq ($(BR2_PACKAGE_JPEG),y)
 LINKS_DEPENDENCIES += jpeg
 endif