Browse Source

Further cleanup of various poky references

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Richard Purdie 13 years ago
parent
commit
fe73ea8c51

+ 7 - 12
README

@@ -1,15 +1,10 @@
-Poky
-====
+OpenEmbedded-Core
+=================
 
-Poky platform builder is a combined cross build system and development 
-environment. It features support for building X11/Matchbox/GTK based 
-filesystem images for various embedded devices and boards. It also 
-supports cross-architecture application development using QEMU emulation
-and a standalone toolchain and SDK with IDE integration.
+For information about OpenEmbedded see their website:
+    http://www.openembedded.org/
 
-Poky has an extensive handbook, the source of which is contained in
-the handbook directory. For compiled HTML or pdf versions of this, 
-see the Poky website http://pokylinux.org.
+The Yocto Project has extensive documentation about OE including a reference manual
+which can be found at:
+    http://yoctoproject.org/community/documentation
 
-Additional information on the specifics of hardware that Poky supports
-is available in README.hardware.

+ 3 - 3
meta/classes/core-image.bbclass

@@ -1,11 +1,11 @@
-# Common for Poky images
+# Common code for generating core reference images
 #
-# Copyright (C) 2007 OpenedHand LTD
+# Copyright (C) 2007-2011 Linux Foundation
 
 LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
                     file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 
-# IMAGE_FEATURES control content of images built with Poky.
+# IMAGE_FEATURES control content of the core reference images
 # 
 # By default we install task-core-boot and task-base packages - this gives us
 # working (console only) rootfs.

+ 1 - 1
meta/classes/imagetest-qemu.bbclass

@@ -29,7 +29,7 @@ def qemuimagetest_main(d):
     import os
     
     """
-    Test Controller for Poky Testing.
+    Test Controller for automated testing.
     """
     
     casestr = re.compile(r'(?P<scen>\w+\b):(?P<case>\w+$)')

+ 2 - 2
meta/classes/license.bbclass

@@ -1,4 +1,4 @@
-# Populates LICENSE_DIRECTORY as set in poky.conf with the license files as set by
+# Populates LICENSE_DIRECTORY as set in distro config with the license files as set by
 # LIC_FILES_CHKSUM. 
 # TODO:
 # - We should also enable the ability to put the generated license directory onto the
@@ -31,7 +31,7 @@ python do_populate_lic() {
     destdir = os.path.join(bb.data.getVar('LICSSTATEDIR', d, True), pn)
     # The license files are located in S/LIC_FILE_CHECKSUM.
     srcdir = bb.data.getVar('S', d, True)
-    # Directory we store the generic licenses as set in poky.conf
+    # Directory we store the generic licenses as set in the distro configuration
     generic_directory = bb.data.getVar('COMMON_LICENSE_DIR', d, True)
     if not generic_directory:
         raise bb.build.FuncFailed("COMMON_LICENSE_DIR is unset. Please set this in your distro config")

+ 1 - 2
meta/conf/bitbake.conf

@@ -528,8 +528,7 @@ SRCPV = "${@bb.fetch2.get_srcrev(d)}"
 
 SRC_URI = "file://${FILE}"
 
-# We can choose which provider of fake root privileges to use
-# default is fakeroot but in Poky we use pseudo
+# Use pseudo as the fakeroot implementation
 PSEUDO_LOCALSTATEDIR ?= "${WORKDIR}/pseudo/"
 FAKEROOTENV = "PSEUDO_PREFIX=${STAGING_DIR_NATIVE}${prefix_native} PSEUDO_LOCALSTATEDIR=${PSEUDO_LOCALSTATEDIR} PSEUDO_NOSYMLINKEXP=1 PSEUDO_DISABLED=0"
 FAKEROOTDIRS = "${PSEUDO_LOCALSTATEDIR}"

+ 2 - 2
meta/recipes-core/initrdscripts/files/init-install.sh

@@ -21,7 +21,7 @@ for device in 'hda' 'hdb' 'sda' 'sdb'
 	  found="yes"
 
 	  while true; do
-	      echo "Found drive at /dev/${device}. Do you want to install poky there ? [y/n]"
+	      echo "Found drive at /dev/${device}. Do you want to install this image there ? [y/n]"
 	      read answer
 	      if [ "$answer" = "y" ] ; then
 		  break
@@ -153,7 +153,7 @@ echo "(hd0) /dev/${device}" > /ssd/boot/grub/device.map
 
 echo "default 0" > /ssd/boot/grub/menu.lst
 echo "timeout 30" >> /ssd/boot/grub/menu.lst
-echo "title Poky-Netbook" >> /ssd/boot/grub/menu.lst
+echo "title Live Boot/Install-Image" >> /ssd/boot/grub/menu.lst
 echo "root  (hd0,0)" >> /ssd/boot/grub/menu.lst
 echo "kernel /boot/vmlinuz root=$rootfs rw $3 $4 quiet" >> /ssd/boot/grub/menu.lst
 

+ 1 - 1
meta/recipes-devtools/prelink/prelink_git.bb

@@ -26,7 +26,7 @@ inherit autotools
 BBCLASSEXTEND = "native"
 
 EXTRA_OECONF = "--disable-selinux --with-pkgversion=${PV}-${PR} \
-	--with-bugurl=http://bugzilla.pokylinux.org/"
+	--with-bugurl=http://bugzilla.yoctoproject.org/"
 
 do_configure_prepend () {
         # Disable documentation!

+ 2 - 2
oe-init-build-env

@@ -1,8 +1,8 @@
 #!/bin/sh
 
-# Poky Build Enviroment Setup Script
+# OE Build Enviroment Setup Script
 #
-# Copyright (C) 2006-2007 OpenedHand Ltd.
+# Copyright (C) 2006-2011 Linux Foundation
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by

+ 1 - 1
scripts/README

@@ -1 +1 @@
-This directory contains Various useful scripts for working with poky
+This directory contains Various useful scripts for working with OE builds

+ 3 - 3
scripts/oe-buildenv-internal

@@ -1,8 +1,8 @@
 #!/bin/sh
 
-# Poky Build Enviroment Setup Script
+# OE-Core Build Enviroment Setup Script
 #
-# Copyright (C) 2006-2007 OpenedHand Ltd.
+# Copyright (C) 2006-2011 Linux Foundation
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -44,7 +44,7 @@ BITBAKEDIR=`readlink -f "$BITBAKEDIR"`
 BUILDDIR=`readlink -f "$BUILDDIR"`
 
 if ! (test -d "$BITBAKEDIR"); then
-    echo >&2 "Error: The bitbake directory ($BITBAKEDIR) does not exist!  Did you source the script in the poky directory?"
+    echo >&2 "Error: The bitbake directory ($BITBAKEDIR) does not exist!  Did you source the script in the correct directory?"
     return
 fi
 

+ 3 - 3
scripts/oe-find-native-sysroot

@@ -1,6 +1,6 @@
 #!/bin/bash
 #
-# Find a native sysroot to use - either from an in-tree Poky build or
+# Find a native sysroot to use - either from an in-tree OE build or
 # from a toolchain installation. It then ensures the variable
 # $OECORE_NATIVE_SYSROOT is set to the sysroot's base directory, and sets 
 # $PSEUDO to the path of the pseudo binary.
@@ -15,7 +15,7 @@
 # you set a variable $SKIP_STRICT_SYSROOT_CHECK to a non-empty string
 # beforehand.
 #
-# Copyright (c) 2010 Intel Corp.
+# Copyright (c) 2010 Linux Foundation
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License version 2 as
@@ -47,7 +47,7 @@ if [ -z "$OECORE_NATIVE_SYSROOT" ]; then
 	fi
     else
 	echo "Error: Unable to locate your native sysroot."
-	echo "Did you forget to source the Poky environment script?"
+	echo "Did you forget to source the build environment setup script?"
 
 	if [ -z "$SKIP_STRICT_SYSROOT_CHECK" ]; then
             exit 1

+ 22 - 13
scripts/oe-setup-builddir

@@ -1,8 +1,8 @@
 #!/bin/sh
 
-# Poky Build Enviroment Setup Script
+# OE Build Enviroment Setup Script
 #
-# Copyright (C) 2006-2007 OpenedHand Ltd.
+# Copyright (C) 2006-2011 Linux Foundation
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -44,7 +44,7 @@ if [ "x" != "x$TEMPLATECONF" ]; then
     if ! (test -d "$TEMPLATECONF"); then
 	# Allow TEMPLATECONF=meta-xyz/conf as a shortcut
 	if [ -d "$OEROOT/$TEMPLATECONF" ]; then
-	    TEMPLATECONF="$OEROOT/$POKYCONF"
+	    TEMPLATECONF="$OEROOT/$TEMPLATECONF"
 	fi
 	if ! (test -d "$TEMPLATECONF"); then
 	    echo >&2 "Error: '$TEMPLATECONF' must be a directory containing local.conf & bblayers.conf"
@@ -60,15 +60,19 @@ if [ "x" = "x$OECORELOCALCONF" ]; then
 fi
 if ! (test -r "$BUILDDIR/conf/local.conf"); then
 cat <<EOM
-You had no conf/local.conf file. Poky has created this configuration file for
-you with some default values. You may wish to edit it to use a different MACHINE
-(target hardware) or enable parallel build options to take advantage of multiple
-cores for example. See the file for more information as common configuration
-options are commented.
-
-Also, for more information see the Poky Reference Manual:
+You had no conf/local.conf file. This configuration file has therefore beend 
+created for you with some default values. You may wish to edit it to use a 
+different MACHINE (target hardware) or enable parallel build options to take 
+advantage of multiple cores for example. See the file for more information as 
+common configuration options are commented.
+
+The Yocto Project has extensive documentation about OE including a reference manual
+which can be found at:
     http://yoctoproject.org/community/documentation
 
+For more information about OpenEmbedded see their website:
+    http://www.openembedded.org/
+
 EOM
     cp -f $OECORELOCALCONF $BUILDDIR/conf/local.conf
 fi
@@ -78,13 +82,18 @@ if [ "x" = "x$OECORELAYERCONF" ]; then
 fi
 if ! (test -r "$BUILDDIR/conf/bblayers.conf"); then
 cat <<EOM
-You had no conf/bblayers.conf file. Poky has created this configuration file for
+You had no conf/bblayers.conf file. The configuration file has been created for
 you with some default values. To add additional metadata layers into your
 configuration please add entries to this file.
 
-For more information see the Poky Reference Manual:
+The Yocto Project has extensive documentation about OE including a reference manual
+which can be found at:
     http://yoctoproject.org/community/documentation
 
+For more information about OpenEmbedded see their website:
+    http://www.openembedded.org/
+
+
 EOM
 
     # Put the abosolute path to the layers in bblayers.conf so we can run
@@ -98,7 +107,7 @@ unset OECORELAYERCONF
 
 cat <<EOM
 
-### Shell environment set up for Poky builds. ###
+### Shell environment set up for builds. ###
 
 You can now run 'bitbake <target>'
 

+ 3 - 3
scripts/runqemu

@@ -1,8 +1,8 @@
 #!/bin/bash
 #
-# Handle running Poky images standalone with QEMU
+# Handle running OE images standalone with QEMU
 #
-# Copyright (C) 2006-2010 Intel Corp.
+# Copyright (C) 2006-2011 Linux Foundation
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License version 2 as
@@ -282,7 +282,7 @@ setup_tmpdir() {
 setup_sysroot() {
 	# Toolchain installs set up $OECORE_NATIVE_SYSROOT in their
 	# environment script. If that variable isn't set, we're
-	# either in an in-tree poky scenario or the environment
+	# either in an in-tree build scenario or the environment
 	# script wasn't source'd.
 	if [ -z "$OECORE_NATIVE_SYSROOT" ]; then
 		setup_tmpdir

+ 1 - 1
scripts/runqemu-export-rootfs

@@ -41,7 +41,7 @@ NFS_EXPORT_DIR=$(cd "$2" && pwd)
 SYSROOT_SETUP_SCRIPT=`which oe-find-native-sysroot`
 if [ -z "$SYSROOT_SETUP_SCRIPT" ]; then
     echo "Error: Unable to find the oe-find-native-sysroot script"
-    echo "Did you forget to source your Poky environment script?"
+    echo "Did you forget to source your build environment setup script?"
     exit 1
 fi
 . $SYSROOT_SETUP_SCRIPT

+ 1 - 1
scripts/runqemu-extract-sdk

@@ -32,7 +32,7 @@ fi
 SYSROOT_SETUP_SCRIPT=`which oe-find-native-sysroot`
 if [ -z "$SYSROOT_SETUP_SCRIPT" ]; then
     echo "Error: Unable to find the oe-find-native-sysroot script"
-    echo "Did you forget to source your Poky environment script?"
+    echo "Did you forget to source your build system environment setup script?"
     exit 1
 fi
 . $SYSROOT_SETUP_SCRIPT

+ 6 - 6
scripts/runqemu-gen-tapdevs

@@ -2,10 +2,10 @@
 #
 # Create a "bank" of tap network devices that can be used by the
 # runqemu script. This script needs to be run as root, and will
-# use the tunctl binary from a Poky sysroot. Note: many Linux distros
-# these days still use an older version of tunctl which does not
-# support the group permissions option, hence the need to use Poky's
-# version.
+# use the tunctl binary from the build system sysroot. Note: many Linux 
+# distros these days still use an older version of tunctl which does not
+# support the group permissions option, hence the need to use the build
+# system provided version.
 #
 # Copyright (C) 2010 Intel Corp.
 #
@@ -26,7 +26,7 @@ usage() {
 	echo "Usage: sudo $0 <gid> <num> <native-sysroot-basedir>"
 	echo "Where <gid> is the numeric group id the tap devices will be owned by"
 	echo "<num> is the number of tap devices to create (0 to remove all)"
-	echo "<native-sysroot-basedir> is the path to Poky's native sysroot"
+	echo "<native-sysroot-basedir> is the path to the build system's native sysroot"
 	exit 1
 }
 
@@ -82,4 +82,4 @@ done
 # The runqemu script will check for this file, and if it exists,
 # will use the existing bank of tap devices without creating
 # additional ones via sudo.
-touch /etc/poky-nosudo
+touch /etc/runqemu-nosudo

+ 2 - 2
scripts/runqemu-ifdown

@@ -2,7 +2,7 @@
 #
 # QEMU network configuration script to bring down tap devices. This
 # utility needs to be run as root, and will use the tunctl binary
-# from a Poky sysroot. 
+# from the native sysroot. 
 #
 # If you find yourself calling this script a lot, you can add the
 # the following to your /etc/sudoers file to be able to run this
@@ -11,7 +11,7 @@
 # <my-username> ALL=NOPASSWD: /path/to/runqemu-ifup
 # <my-username> ALL=NOPASSWD: /path/to/runqemu-ifdown
 #
-# Copyright (c) 2006-2010 Intel Corp.
+# Copyright (c) 2006-2011 Linux Foundation
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License version 2 as

+ 3 - 3
scripts/runqemu-ifup

@@ -1,10 +1,10 @@
 #!/bin/bash
 #
 # QEMU network interface configuration script. This utility needs to
-# be run as root, and will use the tunctl binary from a Poky sysroot.
+# be run as root, and will use the tunctl binary from a native sysroot.
 # Note: many Linux distros these days still use an older version of
 # tunctl which does not support the group permissions option, hence
-# the need to use Poky's version.
+# the need to use build system's version.
 #
 # If you find yourself calling this script a lot, you can add the
 # the following to your /etc/sudoers file to be able to run this
@@ -18,7 +18,7 @@
 # that script, the runqemu script will never end up calling this
 # script.
 #
-# Copyright (c) 2006-2010 Intel Corp.
+# Copyright (c) 2006-2011 Linux Foundation
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License version 2 as

+ 3 - 3
scripts/runqemu-internal

@@ -1,8 +1,8 @@
 #!/bin/bash -x
 
-# Handle running Poky images under qemu
+# Handle running OE images under qemu
 #
-# Copyright (C) 2006-2008 OpenedHand Ltd.
+# Copyright (C) 2006-2011 Linux Foundation
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License version 2 as
@@ -86,7 +86,7 @@ fi
 # This file is created when runqemu-gen-tapdevs creates a bank of tap
 # devices, indicating that the user should not bring up new ones using
 # sudo.
-NOSUDO_FLAG="/etc/poky-nosudo"
+NOSUDO_FLAG="/etc/runqemu-nosudo"
 
 QEMUIFUP=`which runqemu-ifup`
 QEMUIFDOWN=`which runqemu-ifdown`