prelink_git.bb 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. SECTION = "devel"
  2. # Need binutils for libiberty.a
  3. DEPENDS = "elfutils binutils transfig-native"
  4. SUMMARY = "An ELF prelinking utility"
  5. DESCRIPTION = "The prelink package contains a utility which modifies ELF shared libraries \
  6. and executables, so that far fewer relocations need to be resolved at \
  7. runtime and thus programs come up faster."
  8. LICENSE = "GPLv2"
  9. LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
  10. PV = "1.0+git${SRCPV}"
  11. PR = "r2"
  12. SRC_URI = "git://git.yoctoproject.org/prelink-cross.git;protocol=git \
  13. file://prelink.conf \
  14. file://prelink.cron.daily \
  15. file://prelink.default \
  16. file://macros.prelink"
  17. TARGET_OS_ORIG := "${TARGET_OS}"
  18. OVERRIDES_append = ":${TARGET_OS_ORIG}"
  19. S = "${WORKDIR}/git/trunk"
  20. inherit autotools
  21. BBCLASSEXTEND = "native"
  22. EXTRA_OECONF = "--disable-selinux --with-pkgversion=${PV}-${PR} \
  23. --with-bugurl=http://bugzilla.yoctoproject.org/"
  24. do_configure_prepend () {
  25. # Disable documentation!
  26. echo "all:" > ${S}/doc/Makefile.am
  27. }
  28. do_install_append () {
  29. install -d ${D}${sysconfdir}/cron.daily ${D}${sysconfdir}/default ${D}${sysconfdir}/rpm
  30. install -m 0644 ${WORKDIR}/prelink.conf ${D}${sysconfdir}/prelink.conf
  31. install -m 0644 ${WORKDIR}/prelink.cron.daily ${D}${sysconfdir}/cron.daily/prelink
  32. install -m 0644 ${WORKDIR}/prelink.default ${D}${sysconfdir}/default/prelink
  33. install -m 0644 ${WORKDIR}/macros.prelink ${D}${sysconfdir}/rpm/macros.prelink
  34. }
  35. pkg_postinst_prelink() {
  36. #!/bin/sh
  37. if [ "x$D" != "x" ]; then
  38. exit 1
  39. fi
  40. prelink -a
  41. }
  42. pkg_postrm_prelink() {
  43. #!/bin/sh
  44. prelink -au
  45. }