Browse Source

hello-mod_0.1.bb: add RPROVIDES

Although the package will get an automatic prefix "kernel-module", so
the package kernel-module-hello does exist, populating rootfs can
generate an error:
  - nothing provides kernel-module-hello ...

This is quite unfortunate, as this recipe is used as a sample.

Adding RPROVIDES_${PN} += "kernel-module-hello" to the recipe fixes
the problem.

[YOCTO #12641]

Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Juro Bystricky 6 years ago
parent
commit
ca17a7bbea
1 changed files with 2 additions and 0 deletions
  1. 2 0
      meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb

+ 2 - 0
meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb

@@ -13,3 +13,5 @@ S = "${WORKDIR}"
 
 # The inherit of module.bbclass will automatically name module packages with
 # "kernel-module-" prefix as required by the oe-core build environment.
+
+RPROVIDES_${PN} += "kernel-module-hello"