hello-mod_0.1.bb 483 B

1234567891011121314151617
  1. SUMMARY = "Example of how to build an external Linux kernel module"
  2. LICENSE = "GPLv2"
  3. LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
  4. inherit module
  5. SRC_URI = "file://Makefile \
  6. file://hello.c \
  7. file://COPYING \
  8. "
  9. S = "${WORKDIR}"
  10. # The inherit of module.bbclass will automatically name module packages with
  11. # "kernel-module-" prefix as required by the oe-core build environment.
  12. RPROVIDES_${PN} += "kernel-module-hello"