Browse Source

Revert "initramfs-live-install*: fix the "install" boot option"

This patch causes install to fail because /etc/mtab doesn't exist, so revert it
for now until the root problem is fixed.

[ YOCTO #4501 ]

This reverts commit 2f5d41f94c53aaf606de66891c37de0dbd86f54b.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Ross Burton 11 years ago
parent
commit
20ded03159

+ 1 - 0
meta/recipes-core/initrdscripts/files/init-install-efi.sh

@@ -66,6 +66,7 @@ rm -f /etc/udev/scripts/mount*
 umount /dev/${device}* 2> /dev/null || /bin/true
 
 mkdir -p /tmp
+cat /proc/mounts > /etc/mtab
 
 disk_size=$(parted /dev/${device} unit mb print | grep Disk | cut -d" " -f 3 | sed -e "s/MB//")
 

+ 1 - 0
meta/recipes-core/initrdscripts/files/init-install.sh

@@ -77,6 +77,7 @@ if [ ! -b /dev/loop0 ] ; then
 fi
 
 mkdir -p /tmp
+cat /proc/mounts > /etc/mtab
 
 disk_size=$(parted /dev/${device} unit mb print | grep Disk | cut -d" " -f 3 | sed -e "s/MB//")
 

+ 1 - 1
meta/recipes-core/initrdscripts/initramfs-live-install-efi_1.0.bb

@@ -3,7 +3,7 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 SRC_URI = "file://init-install-efi.sh"
 
-PR = "r1"
+PR = "r0"
 
 RDEPENDS_${PN} = "parted e2fsprogs-mke2fs dosfstools"
 

+ 1 - 1
meta/recipes-core/initrdscripts/initramfs-live-install_1.0.bb

@@ -3,7 +3,7 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 SRC_URI = "file://init-install.sh"
 
-PR = "r9"
+PR = "r8"
 
 RDEPENDS_${PN} = "grub parted e2fsprogs-mke2fs"