Browse Source

powertop: inherit gettext

powertop uses gettext during config time and at build time to generate the
messages, so really should inherit gettext.

[YOCTO #4470]

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Ross Burton 11 years ago
parent
commit
5eedfe3fd8
1 changed files with 4 additions and 2 deletions
  1. 4 2
      meta/recipes-kernel/powertop/powertop_1.13.bb

+ 4 - 2
meta/recipes-kernel/powertop/powertop_1.13.bb

@@ -6,12 +6,12 @@ BUGTRACKER = "http://bugzilla.lesswatts.org/"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
 
-DEPENDS = "virtual/libintl ncurses"
+DEPENDS = "ncurses"
 
 # powertop 1.13 needs lspci
 RDEPENDS_${PN} = "pciutils"
 
-PR = "r4"
+PR = "r5"
 
 SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz \
            file://stub_out_the_ncurses_calls_in_dump_mode.patch \
@@ -20,6 +20,8 @@ SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.ta
 SRC_URI[md5sum] = "78aa17c8f55178004223bf236654298e"
 SRC_URI[sha256sum] = "2bc866089496877dd26d2d316ad5763ab8ecb5e28aefba44bc5d355dcdc58d98"
 
+inherit gettext
+
 CFLAGS += "${LDFLAGS}"
 EXTRA_OEMAKE = "VERSION=\"${PV}\" EXTRA_LIBS=${EXTRA_LIBS}"