Browse Source

python3-psutil: Upgrade 5.7.2 -> 5.7.3

Upgrade to release 5.7.3:

- [FreeBSD] add support for Process.rlimit().
- [BSD] add support for Process.environ()
- [UNIX] net_if_stats()'s isup also checks whether the NIC is
  running (meaning Wi-Fi or ethernet cable is connected)
- [Linux] improved battery detection and charge "secsleft"
  calculation
- [Linux] physical cpu_count() result is incorrect on systems with
  more than one CPU socket
- [macOS] Process.exe() may raise FileNotFoundError if process is
  still alive but the exe file which launched it got deleted
- [macOS] fix missing include for getpagesize()
- [Windows] Process.open_files() may cause a segfault due to a
  NULL pointer
- [Linux] sensors_battery(): if percent can be determined but not
  the remaining values, still return a result instead of None.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Leon Anavi 3 years ago
parent
commit
e37647c283
1 changed files with 2 additions and 3 deletions
  1. 2 3
      meta-python/recipes-devtools/python/python3-psutil_5.7.3.bb

+ 2 - 3
meta-python/recipes-devtools/python/python3-psutil_5.7.2.bb → meta-python/recipes-devtools/python/python3-psutil_5.7.3.bb

@@ -2,9 +2,8 @@ SUMMARY = "A cross-platform process and system utilities module for Python"
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=e35fd9f271d19d5f742f20a9d1f8bb8b"
 
-PYPI_SRC_URI = "https://files.pythonhosted.org/packages/aa/3e/d18f2c04cf2b528e18515999b0c8e698c136db78f62df34eee89cee205f1/psutil-${PV}.tar.gz"
-SRC_URI[md5sum] = "50bf39b4faa268ba1da8a9730bb38bb6"
-SRC_URI[sha256sum] = "90990af1c3c67195c44c9a889184f84f5b2320dce3ee3acbd054e3ba0b4a7beb"
+SRC_URI[md5sum] = "b07a067e6a930608235f4e5d9b1f90f5"
+SRC_URI[sha256sum] = "af73f7bcebdc538eda9cc81d19db1db7bf26f103f91081d780bbacfcb620dee2"
 
 inherit pypi setuptools3