Browse Source

python3-cryptography: Upgrade 3.1.1 -> 3.2

Upgrade to release 3.2:

- SECURITY ISSUE: Attempted to make RSA PKCS#1v1.5 decryption more
  constant time, to protect against Bleichenbacher vulnerabilities.
  Due to limitations imposed by our API, we cannot completely
  mitigate this vulnerability and a future release will contain a
  new API which is designed to be resilient to these for contexts
  where it is required. Credit to Hubert Kario for reporting the
  issue. CVE-2020-25659
- Support for OpenSSL 1.0.2 has been removed. Users on older
  version of OpenSSL will need to upgrade.
- Added basic support for PKCS7 signing (including SMIME) via
  :class:`~cryptography.hazmat.primitives.serialization.pkcs7.PKCS7SignatureBuilder`.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Leon Anavi 3 years ago
parent
commit
a00b9d8eba
1 changed files with 2 additions and 2 deletions
  1. 2 2
      meta-python/recipes-devtools/python/python3-cryptography_3.2.bb

+ 2 - 2
meta-python/recipes-devtools/python/python3-cryptography_3.1.1.bb → meta-python/recipes-devtools/python/python3-cryptography_3.2.bb

@@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=097f805837700cfac572ac274cd38124"
 
 LDSHARED += "-pthread"
 
-SRC_URI[md5sum] = "c3807891d36aa9de8187e9db8b2bb457"
-SRC_URI[sha256sum] = "9d9fc6a16357965d282dd4ab6531013935425d0dc4950df2e0cf2a1b1ac1017d"
+SRC_URI[md5sum] = "1e476287399bae923514e19429804155"
+SRC_URI[sha256sum] = "e4789b84f8dedf190148441f7c5bfe7244782d9cbb194a36e17b91e7d3e1cca9"
 
 SRC_URI += " \
     file://run-ptest \