소스 검색

Adding recipe for exprtk

The C++ Mathematical Expression  Toolkit Library (ExprTk) is  a simple
to  use,   easy  to   integrate  and   extremely  efficient   run-time
mathematical  expression parsing  and evaluation  engine. The  parsing
engine  supports numerous  forms  of  functional and  logic processing
semantics and is easily extensible.

It is a header only library.

Signed-off-by: Vijay Khemka <vijaykhemka@fb.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Vijay Khemka 3 년 전
부모
커밋
dd0fafdc53
1개의 변경된 파일22개의 추가작업 그리고 0개의 파일을 삭제
  1. 22 0
      meta-oe/recipes-devtools/exprtk/exprtk_git.bb

+ 22 - 0
meta-oe/recipes-devtools/exprtk/exprtk_git.bb

@@ -0,0 +1,22 @@
+SUMMARY = "Expression parser"
+HOMEPAGE = "https://github.com/ArashPartow/exprtk"
+SECTION = "libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+SRCREV = "281c2ccc65b8f91c012ea3725ebcef406378a225"
+
+SRC_URI = "git://github.com/ArashPartow/exprtk.git"
+
+S = "${WORKDIR}/git"
+
+# other packages commonly reference the file directly as "exprtk.hpp"
+# create symlink to allow this usage
+do_install() {
+    install -d ${D}/${includedir}
+    install -m 0644 ${S}/exprtk.hpp ${D}/${includedir}/exprtk.hpp
+}
+
+# exprtk is a header only C++ library, so the main package will be empty.
+RDEPENDS_${PN}-dev = ""
+
+BBCLASSEXTEND = "native nativesdk"