exprtk_git.bb 692 B

12345678910111213141516171819202122
  1. SUMMARY = "Expression parser"
  2. HOMEPAGE = "https://github.com/ArashPartow/exprtk"
  3. SECTION = "libs"
  4. LICENSE = "MIT"
  5. LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
  6. SRCREV = "281c2ccc65b8f91c012ea3725ebcef406378a225"
  7. SRC_URI = "git://github.com/ArashPartow/exprtk.git"
  8. S = "${WORKDIR}/git"
  9. # other packages commonly reference the file directly as "exprtk.hpp"
  10. # create symlink to allow this usage
  11. do_install() {
  12. install -d ${D}/${includedir}
  13. install -m 0644 ${S}/exprtk.hpp ${D}/${includedir}/exprtk.hpp
  14. }
  15. # exprtk is a header only C++ library, so the main package will be empty.
  16. RDEPENDS_${PN}-dev = ""
  17. BBCLASSEXTEND = "native nativesdk"