Quellcode durchsuchen

daemontools: use u-a for /usr/bin/svc and /usr/bin/svok

* busybox provides the same, causing busybox postinst to fail when both packages
  are installed in the same image:
  update-alternatives: Error: not linking rootfs/usr/bin/svc to /usr/bin/busybox.nosuid since rootfs/usr/bin/svc exists and is not a link
  update-alternatives: Error: not linking rootfs/usr/bin/svok to /usr/bin/busybox.nosuid since rootfs/usr/bin/svok exists and is not a link

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Martin Jansa vor 4 Jahren
Ursprung
Commit
b3013a0bc9
1 geänderte Dateien mit 4 neuen und 0 gelöschten Zeilen
  1. 4 0
      meta-oe/recipes-support/daemontools/daemontools_0.76.bb

+ 4 - 0
meta-oe/recipes-support/daemontools/daemontools_0.76.bb

@@ -38,3 +38,7 @@ do_install() {
 do_install_append_class-target() {
     install -m755 ${S}/command/* ${D}/${bindir}
 }
+
+inherit update-alternatives
+ALTERNATIVE_PRIORITY = "100"
+ALTERNATIVE_${PN} = "svc svok"