daemontools_0.76.bb 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. SUMMARY = "DJB daemontools"
  2. HOMEPAGE = "http://cr.yp.to/daemontools.html"
  3. DESCRIPTION = "supervise monitors a service. It starts the service and restarts the \
  4. service if it dies. The companion svc program stops, pauses, or restarts \
  5. the service on sysadmin request. The svstat program prints a one-line \
  6. status report. \
  7. multilog saves error messages to one or more logs. It optionally timestamps \
  8. each line and, for each log, includes or excludes lines matching specified \
  9. patterns. It automatically rotates logs to limit the amount of disk space \
  10. used. If the disk fills up, it pauses and tries again, without losing any \
  11. data."
  12. SECTION = "System/Servers"
  13. LIC_FILES_CHKSUM = "file://src/prot.c;beginline=1;endline=1;md5=96964cadf07e8f8c1e2ffb3b507dd647"
  14. LICENSE = "PD"
  15. SRC_URI = "http://cr.yp.to/daemontools/${BPN}-${PV}.tar.gz \
  16. file://0001-error.h-include-errno.h-instead-of-extern-int.diff \
  17. file://0002-supervise.c-.-supervise-may-be-a-symlink-if-it-s-da.diff \
  18. file://cross-compile.patch \
  19. file://0001-daemontools-Fix-QA-Issue.patch \
  20. "
  21. SRC_URI[md5sum] = "1871af2453d6e464034968a0fbcb2bfc"
  22. SRC_URI[sha256sum] = "a55535012b2be7a52dcd9eccabb9a198b13be50d0384143bd3b32b8710df4c1f"
  23. S = "${WORKDIR}/admin/${BP}"
  24. do_compile() {
  25. ./package/compile
  26. }
  27. do_install() {
  28. install -d ${D}/${bindir}
  29. }
  30. do_install_append_class-target() {
  31. install -m755 ${S}/command/* ${D}/${bindir}
  32. }
  33. inherit update-alternatives
  34. ALTERNATIVE_PRIORITY = "100"
  35. ALTERNATIVE_${PN} = "svc svok"