瀏覽代碼

libsoc: use python3 for python bindings

With python in PACKAGECONFIGS and with the removal of python2 from
host tools the recipe fails to build. Change the recipe to use python3.

libsoc configure uses the host python to detect the used version,
install and use the python3-native package to have the same version
for host and target.

Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Max Krummenacher 4 年之前
父節點
當前提交
a04e0ed79f
共有 1 個文件被更改,包括 2 次插入2 次删除
  1. 2 2
      meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb

+ 2 - 2
meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb

@@ -7,7 +7,7 @@ HOMEPAGE = "https://github.com/jackmitch/libsoc"
 LICENSE = "LGPLv2.1"
 LIC_FILES_CHKSUM = "file://LICENCE;md5=e0bfebea12a718922225ba987b2126a5"
 
-inherit autotools pkgconfig python-dir
+inherit autotools pkgconfig python3-dir
 
 SRCREV = "fd1ad6e7823fa76d8db0d3c5884faffa8ffddafb"
 SRC_URI = "git://github.com/jackmitch/libsoc.git"
@@ -21,7 +21,7 @@ PACKAGECONFIG ?= ""
 PACKAGECONFIG[disabledebug] = "--disable-debug,,"
 PACKAGECONFIG[allboardconfigs] = "--with-board-configs,,"
 PACKAGECONFIG[enableboardconfig] = "--enable-board=${BOARD},,"
-PACKAGECONFIG[python] = "--enable-python=${PYTHON_PN},,${PYTHON_PN}"
+PACKAGECONFIG[python] = "--enable-python=${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN},,${PYTHON_PN} ${PYTHON_PN}-native"
 
 PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'python', \
     '${PYTHON_PN}-libsoc-staticdev ${PYTHON_PN}-libsoc', '', d)}"