libsoc_0.8.2.bb 1.2 KB

1234567891011121314151617181920212223242526272829303132
  1. SUMMARY = "Library for interfacing with common SoC peripherals"
  2. DESCRIPTION = "libsoc is a C library to interface with common peripherals (gpio, i2c, spi, pwm) \
  3. found in SoC (System on Chips) through generic Linux Kernel interfaces."
  4. HOMEPAGE = "https://github.com/jackmitch/libsoc"
  5. LICENSE = "LGPLv2.1"
  6. LIC_FILES_CHKSUM = "file://LICENCE;md5=e0bfebea12a718922225ba987b2126a5"
  7. inherit autotools pkgconfig python3-dir
  8. SRCREV = "fd1ad6e7823fa76d8db0d3c5884faffa8ffddafb"
  9. SRC_URI = "git://github.com/jackmitch/libsoc.git"
  10. S = "${WORKDIR}/git"
  11. BOARD ??= "devboard"
  12. PACKAGECONFIG ?= ""
  13. PACKAGECONFIG[disabledebug] = "--disable-debug,,"
  14. PACKAGECONFIG[allboardconfigs] = "--with-board-configs,,"
  15. PACKAGECONFIG[enableboardconfig] = "--enable-board=${BOARD},,"
  16. PACKAGECONFIG[python] = "--enable-python=${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN},,${PYTHON_PN} ${PYTHON_PN}-native"
  17. PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'python', \
  18. '${PYTHON_PN}-libsoc-staticdev ${PYTHON_PN}-libsoc', '', d)}"
  19. RDEPENDS_${PN} = "libgcc"
  20. FILES_${PYTHON_PN}-libsoc-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*/*.a"
  21. FILES_${PYTHON_PN}-libsoc += "${PYTHON_SITEPACKAGES_DIR}"