Browse Source

kexecboot: Use -fcommon to compile

gcc10 defaults to -fno-common and kexecboot does not compile with
-fno-common, so use -fcommon explicitly

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 3 years ago
parent
commit
95bf58c16e
1 changed files with 2 additions and 0 deletions
  1. 2 0
      meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb

+ 2 - 0
meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb

@@ -13,6 +13,8 @@ inherit autotools
 
 EXTRA_OECONF = "--enable-textui --enable-delay=2 --enable-evdev-rate=1000,250"
 
+CFLAGS += "-fcommon"
+
 do_install () {
     install -D -m 0755 ${B}/src/kexecboot ${D}${bindir}/kexecboot
     install -d ${D}/proc