kexecboot_git.bb 992 B

12345678910111213141516171819202122232425262728293031323334
  1. SUMMARY = "kexecboot linux-as-bootloader"
  2. DESCRIPTION = "kexecboot is a graphical linux-as-bootloader implementation based on kexec."
  3. HOMEPAGE = "http://kexecboot.org"
  4. LICENSE = "GPLv2"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
  6. PV = "0.6+git${SRCPV}"
  7. S = "${WORKDIR}/git"
  8. SRC_URI = "git://github.com/kexecboot/kexecboot.git"
  9. SRC_URI_append_libc-klibc = " file://0001-kexecboot-Use-new-reboot-API-with-klibc.patch "
  10. SRCREV = "5a5e04be206140059f42ac786d424da1afaa04b6"
  11. inherit autotools
  12. EXTRA_OECONF = "--enable-textui --enable-delay=2 --enable-evdev-rate=1000,250"
  13. CFLAGS += "-fcommon"
  14. do_install () {
  15. install -D -m 0755 ${B}/src/kexecboot ${D}${bindir}/kexecboot
  16. install -d ${D}/proc
  17. install -d ${D}/mnt
  18. install -d ${D}/dev
  19. install -d ${D}/sys
  20. }
  21. PACKAGE_ARCH = "${MACHINE_ARCH}"
  22. FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev /sys"
  23. pkg_postinst_${PN} () {
  24. ln -sf ${bindir}/kexecboot $D/init
  25. }
  26. BBCLASSEXTEND = "klibc"