Kaynağa Gözat

procmail: Use build ldflags when invoking native compile/link

Some older compilers do not support security flags like -fstack-protector=strong
and if we do not set this then it will use the target flags to pass here
which will fail with gcc < 5.x, especially a problem building distros with
security flags on host with 4.x gcc e.g. ubuntu 14.04

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 6 yıl önce
ebeveyn
işleme
8b7834aba8

+ 1 - 1
meta-oe/recipes-support/procmail/procmail_3.22.bb

@@ -29,7 +29,7 @@ do_configure() {
     export CFLAGS="${BUILD_CFLAGS}"
     export AR="${BUILD_AR}"
     export AS="${BUILD_AS}"
-    make TARGET_CFLAGS="$TARGET_CFLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" LDFLAGS0="${LDFLAGS}" autoconf.h
+    make TARGET_CFLAGS="$TARGET_CFLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" LDFLAGS0="${BUILD_LDFLAGS}" autoconf.h
 }
 
 do_compile() {