procmail_3.22.bb 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. SUMMARY = "Mail processing program"
  2. DESCRIPTION = "Procmail can be used to create mail-servers, mailing lists, sort your\
  3. incoming mail into separate folders/files (real convenient when subscribing\
  4. to one or more mailing lists or for prioritising your mail), preprocess\
  5. your mail, start any programs upon mail arrival (e.g. to generate different\
  6. chimes on your workstation for different types of mail) or selectively\
  7. forward certain incoming mail automatically to someone."
  8. HOMEPAGE = "http://www.procmail.org/"
  9. SECTION = "Applications/System"
  10. SRC_URI = "http://www.ring.gr.jp/archives/net/mail/${BPN}/${BP}.tar.gz \
  11. file://from-debian-to-fix-compile-errors.patch \
  12. file://from-debian-to-modify-parameters.patch \
  13. file://from-debian-to-fix-man-file.patch \
  14. file://man-file-mailstat.1-from-debian.patch"
  15. SRC_URI[md5sum] = "1678ea99b973eb77eda4ecf6acae53f1"
  16. SRC_URI[sha256sum] = "087c75b34dd33d8b9df5afe9e42801c9395f4bf373a784d9bc97153b0062e117"
  17. LICENSE = "GPL-2.0 & Artistic-1.0"
  18. LIC_FILES_CHKSUM = "file://COPYING;md5=a71e50e197a992c862379e576e669757 \
  19. file://Artistic;md5=505e00d03c3428cde21b17b2a386590e"
  20. DEPENDS = "libnet"
  21. inherit autotools-brokensep
  22. do_configure() {
  23. find examples -type f | xargs chmod 644
  24. export CC="${BUILD_CC}"
  25. export LD="${BUILD_LD}"
  26. export CFLAGS="${BUILD_CFLAGS}"
  27. export AR="${BUILD_AR}"
  28. export AS="${BUILD_AS}"
  29. make TARGET_CFLAGS="$TARGET_CFLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" LDFLAGS0="${BUILD_LDFLAGS}" autoconf.h
  30. }
  31. do_compile() {
  32. oe_runmake -i TARGET_CFLAGS="$TARGET_CFLAGS -Wno-comments -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" LDFLAGS0="${LDFLAGS}"
  33. }
  34. do_install() {
  35. install -d ${D}${bindir}
  36. install -d ${D}${mandir}/man1
  37. install -d ${D}${mandir}/man5
  38. oe_runmake -i BASENAME=${D}/usr MANDIR=${D}${mandir} install
  39. install -m 0644 debian/mailstat.1 ${D}${mandir}/man1
  40. }