소스 검색

consolation: Add recipe

Consolation is a daemon that provide copy-paste and scrolling support to
the Linux console.

It is based on the libinput library and supports all pointer devices and
settings provided by this library,

Similar software include gpm and jamd.

Signed-off-by: Robert Joslyn <robert.joslyn@redrectangle.org>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Robert Joslyn 3 년 전
부모
커밋
87229e8aae
2개의 변경된 파일30개의 추가작업 그리고 0개의 파일을 삭제
  1. 1 0
      meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
  2. 29 0
      meta-oe/recipes-support/consolation/consolation_0.0.8.bb

+ 1 - 0
meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb

@@ -686,6 +686,7 @@ RDEPENDS_packagegroup-meta-oe-support ="\
     c-ares \
     cmark \
     ${@bb.utils.contains("DISTRO_FEATURES", "polkit gobject-introspection-data", "colord", "", d)} \
+    consolation \
     cpprest \
     ctapi-common \
     dfu-util \

+ 29 - 0
meta-oe/recipes-support/consolation/consolation_0.0.8.bb

@@ -0,0 +1,29 @@
+SUMMARY = "copy-paste for the Linux console"
+DESCRIPTION = "Consolation is a daemon that provides copy-paste and scrolling \
+support to the Linux console. It is based on the libinput library and \
+supports all pointer devices and settings provided by this library. Similar \
+software include gpm and jamd."
+HOMEPAGE = "https://salsa.debian.org/consolation-team/consolation"
+SECTION = "console/utils"
+LICENSE = "GPL-2.0+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=73ca626e1d9048abfc7d599370650827"
+
+DEPENDS = " \
+    libevdev \
+    libinput \
+    udev \
+"
+
+SRC_URI = "git://salsa.debian.org/consolation-team/consolation.git"
+SRCREV = "4581eaece6e49fa2b687efbdbe23b2de452e7902"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig systemd
+
+do_install_append() {
+    install -d ${D}${systemd_system_unitdir}
+    install -m 644 ${B}/consolation.service ${D}${systemd_system_unitdir}
+}
+
+SYSTEMD_SERVICE_${PN} = "consolation.service"