consolation_0.0.8.bb 923 B

1234567891011121314151617181920212223242526272829
  1. SUMMARY = "copy-paste for the Linux console"
  2. DESCRIPTION = "Consolation is a daemon that provides copy-paste and scrolling \
  3. support to the Linux console. It is based on the libinput library and \
  4. supports all pointer devices and settings provided by this library. Similar \
  5. software include gpm and jamd."
  6. HOMEPAGE = "https://salsa.debian.org/consolation-team/consolation"
  7. SECTION = "console/utils"
  8. LICENSE = "GPL-2.0+"
  9. LIC_FILES_CHKSUM = "file://LICENSE;md5=73ca626e1d9048abfc7d599370650827"
  10. DEPENDS = " \
  11. libevdev \
  12. libinput \
  13. udev \
  14. "
  15. SRC_URI = "git://salsa.debian.org/consolation-team/consolation.git"
  16. SRCREV = "4581eaece6e49fa2b687efbdbe23b2de452e7902"
  17. S = "${WORKDIR}/git"
  18. inherit autotools pkgconfig systemd
  19. do_install_append() {
  20. install -d ${D}${systemd_system_unitdir}
  21. install -m 644 ${B}/consolation.service ${D}${systemd_system_unitdir}
  22. }
  23. SYSTEMD_SERVICE_${PN} = "consolation.service"