瀏覽代碼

libauthen-radius-perl: ptest requires meta-networking to be present

Since commit [d7ea637 recipes-devtools: Move back from
meta-networking to meta-perl] applied, but freeradius
locates in meta-networking

If meta-networking not present and ptest enable, skip it

Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Hongxu Jia 5 年之前
父節點
當前提交
7db5a30511
共有 1 個文件被更改,包括 9 次插入1 次删除
  1. 9 1
      meta-perl/recipes-perl/libauthen/libauthen-radius-perl_0.22.bb

+ 9 - 1
meta-perl/recipes-perl/libauthen/libauthen-radius-perl_0.22.bb

@@ -34,6 +34,14 @@ RDEPENDS_${PN} += "\
     perl-module-io-select \
     perl-module-io-socket \
 "
-RDEPENDS_${PN}-ptest += "freeradius"
+RDEPENDS_${PN}-ptest += " \
+    ${@bb.utils.contains('PTEST_ENABLED', '1', 'freeradius', '', d)} \
+"
 
 BBCLASSEXTEND = "native"
+
+python() {
+    if bb.utils.contains('PTEST_ENABLED', '1', 'True', 'False', d) and \
+       'networking-layer' not in d.getVar('BBFILE_COLLECTIONS').split():
+        raise bb.parse.SkipRecipe('ptest requires meta-networking to be present.')
+}